-
Notifications
You must be signed in to change notification settings - Fork 0
/
MirrorImageTriangle.java
54 lines (46 loc) · 1.39 KB
/
MirrorImageTriangle.java
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
import java.util.*;
class Solution {
public static void print(int n) {
int i,k=0;
for(i=0;i<=n;i++){
k=-1*i;
for(int j=0;j<=n+i;j++){
if(i+j>=n){
System.out.print(Math.abs(k));
k++;
}
else
System.out.print(" ");
}
System.out.println();
}
//Write your code here
/*
Print the following pattern for the given number of rows.
Pattern for N = 2
0
101
21012
Input format : N (Total no. of rows)
Output format : Pattern in N lines
Sample Input :
6
Sample Output :
0
101
21012
3210123
432101234
54321012345
6543210123456
*/
}
}
class MirrorImageTriangle{
public static void main(String[] args) {
Scanner sc=new Scanner(System.in);
Solution s=new Solution();
int row=sc.nextInt();
s.print(row);
}
}