Skip to content

Commit

Permalink
bump: version 0.0.1 → 0.1.0
Browse files Browse the repository at this point in the history
  • Loading branch information
15r10nk committed Feb 11, 2024
1 parent df5f42c commit a7de40b
Show file tree
Hide file tree
Showing 3 changed files with 30 additions and 4 deletions.
26 changes: 26 additions & 0 deletions CHANGELOG.md
Original file line number Diff line number Diff line change
@@ -0,0 +1,26 @@
## v0.1.0 (2024-02-11)

### Feat

- support for namespace packages
- added `lazy-imports-lite preview` command
- allow setattr for lazy module attributes
- raise LazyImportError if an error is raised during the lazy importing of a module
- disable lazy-imports with LAZY_IMPORTS_LITE_DISABLE
- loader works for simple examples
- implemented import & import as
- globals returns the imported modules
- globals returns the imported modules

### Fix

- support packages with different names than the project
- fixed windows support
- use __package__ to find modules
- fixed some issues
- hide LazyObjects from modules

### Refactor

- scan distributions at startup
- renamed v to _lazy_value
2 changes: 1 addition & 1 deletion pyproject.toml
Original file line number Diff line number Diff line change
Expand Up @@ -26,7 +26,7 @@ license = "MIT"
name = "lazy-imports-lite"
readme = "README.md"
requires-python = ">=3.8"
version="0.0.1"
version="0.1.0"


[project.scripts]
Expand Down
6 changes: 3 additions & 3 deletions src/lazy_imports_lite/__init__.py
Original file line number Diff line number Diff line change
@@ -1,3 +1,3 @@
from contextlib import nullcontext as eager_imports

from ._hooks import LazyImportError
from contextlib import nullcontext as eager_imports

from ._hooks import LazyImportError

0 comments on commit a7de40b

Please sign in to comment.