Skip to content

Commit

Permalink
Update variables to inclusive naming
Browse files Browse the repository at this point in the history
After running poky/scripts/contrib/convert-variable-renames.py

Signed-off-by: Tim Orling <[email protected]>
  • Loading branch information
moto-timo authored and robwoolley committed Nov 27, 2023
1 parent 875464b commit 1bc2876
Show file tree
Hide file tree
Showing 40 changed files with 3,037 additions and 3,037 deletions.
Original file line number Diff line number Diff line change
Expand Up @@ -12,8 +12,8 @@
DISTRO_FEATURES_NO_LIBC = "${@ ' '.join(sorted(set([f for f in (d.getVar('DISTRO_FEATURES') or '').split() if not f.startswith('libc-')]))) }"
ROS_EXTRA_BUILDCFG_VARS:append = " INHERIT DISTRO_FEATURES_NO_LIBC MACHINE_FEATURES IMAGE_FEATURES"

# Include LICENSE_FLAGS_WHITELIST unless it's unset or just whitespace.
ROS_EXTRA_BUILDCFG_VARS:append = "${@ ' LICENSE_FLAGS_WHITELIST' if len((d.getVar('LICENSE_FLAGS_WHITELIST') or '').split()) > 0 else '' }"
# Include LICENSE_FLAGS_ACCEPTED unless it's unset or just whitespace.
ROS_EXTRA_BUILDCFG_VARS:append = "${@ ' LICENSE_FLAGS_ACCEPTED' if len((d.getVar('LICENSE_FLAGS_ACCEPTED') or '').split()) > 0 else '' }"

# Include IMAGE_FSTYPES unless it's unset or just whitespace.
ROS_EXTRA_BUILDCFG_VARS:append = "${@ ' IMAGE_FSTYPES' if len((d.getVar('IMAGE_FSTYPES') or '').split()) > 0 else '' }"

Large diffs are not rendered by default.

Original file line number Diff line number Diff line change
Expand Up @@ -42,7 +42,7 @@ do_iinstall:append() {
rm -rf ${D}${STAGING_DIR}
}

PNBLACKLIST[wxpython] ?= "${@bb.utils.contains('ROS_WORLD_SKIP_GROUPS', 'wxpython', 'Does not build: ld: cannot find -lwx_gtk3u_xrc-3.0', '', d)}"
SKIP_RECIPE[wxpython] ?= "${@bb.utils.contains('ROS_WORLD_SKIP_GROUPS', 'wxpython', 'Does not build: ld: cannot find -lwx_gtk3u_xrc-3.0', '', d)}"

inherit features_check
# Depends on wxwidgets with this restriction:
Expand Down

Large diffs are not rendered by default.

Original file line number Diff line number Diff line change
Expand Up @@ -236,13 +236,13 @@ ROS_WORLD_SKIP_GROUPS += "${@bb.utils.contains('DISTRO_FEATURES', 'x11', '', 'x1
# recipes depending on 'opengl' in DISTRO_FEATURES
ROS_WORLD_SKIP_GROUPS += "${@bb.utils.contains('DISTRO_FEATURES', 'opengl', '', 'opengl', d)}"
# recipes depending on 'ffmpeg' which is restricted by 'commercial' LICENSE_FLAG
ROS_WORLD_SKIP_GROUPS += "${@bb.utils.contains_any('LICENSE_FLAGS_WHITELIST', ['commercial', 'ffmpeg', 'commercial_ffmpeg'], '', 'ffmpeg', d)}"
ROS_WORLD_SKIP_GROUPS += "${@bb.utils.contains_any('LICENSE_FLAGS_ACCEPTED', ['commercial', 'ffmpeg', 'commercial_ffmpeg'], '', 'ffmpeg', d)}"
# recipes depending on 'x264' (ffmpeg does depend on it by default as well) which is restricted by 'commercial' LICENSE_FLAG
ROS_WORLD_SKIP_GROUPS += "${@bb.utils.contains_any('LICENSE_FLAGS_WHITELIST', ['commercial', 'x264', 'commercial_x264'], '', 'x264', d)}"
ROS_WORLD_SKIP_GROUPS += "${@bb.utils.contains_any('LICENSE_FLAGS_ACCEPTED', ['commercial', 'x264', 'commercial_x264'], '', 'x264', d)}"
# recipes depending on 'gstreamer1.0-plugins-ugly' which is restricted by 'commercial' LICENSE_FLAG
ROS_WORLD_SKIP_GROUPS += "${@bb.utils.contains_any('LICENSE_FLAGS_WHITELIST', ['commercial', 'gstreamer1.0-plugins-ugly', 'commercial_gstreamer1.0-plugins-ugly'], '', 'gst-ugly', d)}"
ROS_WORLD_SKIP_GROUPS += "${@bb.utils.contains_any('LICENSE_FLAGS_ACCEPTED', ['commercial', 'gstreamer1.0-plugins-ugly', 'commercial_gstreamer1.0-plugins-ugly'], '', 'gst-ugly', d)}"
# recipes depending on vlc from meta-multimedia layer which depends on ffmpeg which has commercial LICENSE_FLAGS restriction
ROS_WORLD_SKIP_GROUPS += "${@bb.utils.contains_any('LICENSE_FLAGS_WHITELIST', ['commercial', 'vlc', 'commercial_vlc'], '', 'vlc', d)}"
ROS_WORLD_SKIP_GROUPS += "${@bb.utils.contains_any('LICENSE_FLAGS_ACCEPTED', ['commercial', 'vlc', 'commercial_vlc'], '', 'vlc', d)}"

# recipes depending on python*-pyqt5 from meta-qt5 layer
# Use separate group, because e.g. webOS OSE has meta-qt5 layer included, but python*-pyqt5
Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -12,4 +12,4 @@
# but it's unclear what is relation between 0.4.2-1 catkin-ized version and "date" release tags in upstream:
# catkin-ized: https://github.com/Eurecat/abseil_cpp-release/tree/release/melodic%2Fabseil_cpp%2F0.4.2-1
# upstream: https://github.com/abseil/abseil-cpp (https://github.com/abseil/abseil-cpp/releases)
PNBLACKLIST[abseil-cpp] ?= "It is a catkin-ized edition of the upstream version that is not used by any other ROS 1 package and this one isn't compatible with grpc-1.35.0 recipe currently in meta-oe (unlike the abseil-cpp recipe for 20200923+git${SRCPV} version also in meta-oe)"
SKIP_RECIPE[abseil-cpp] ?= "It is a catkin-ized edition of the upstream version that is not used by any other ROS 1 package and this one isn't compatible with grpc-1.35.0 recipe currently in meta-oe (unlike the abseil-cpp recipe for 20200923+git${SRCPV} version also in meta-oe)"
Original file line number Diff line number Diff line change
@@ -1,3 +1,3 @@
# Copyright (c) 2020 LG Electronics, Inc.

PNBLACKLIST[flatbuffers] ?= "It is a fork of https://github.com/google/flatbuffers that's not used by any other ROS 1 package."
SKIP_RECIPE[flatbuffers] ?= "It is a fork of https://github.com/google/flatbuffers that's not used by any other ROS 1 package."
Original file line number Diff line number Diff line change
@@ -1,6 +1,6 @@
# Copyright (c) 2020 LG Electronics, Inc.

PNBLACKLIST[grpc] ?= "It is a catkin-ized edition of the upstream version that is not used by any other ROS 1 package."
SKIP_RECIPE[grpc] ?= "It is a catkin-ized edition of the upstream version that is not used by any other ROS 1 package."

# NOTE: VERBOSE=1 cmake --build /jenkins/mjansa/build-ros/webos-melodic-thud/tmp-glibc/work/raspberrypi4-webos-linux-gnueabi/grpc/0.0.10-r0/build --target all -- -j 32
# ninja: error: build.ninja:1064: bad $-escape (literal $ must be written as $$)
Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -1219,7 +1219,7 @@ ROS_SUPERFLORE_GENERATED_WORLD_PACKAGES_DEPENDING_ON_META_QT5 = " \
webots-ros \
"

# OE won't let us build ffmpeg unless LICENSE_FLAGS_WHITELIST contains "commercial" or "commercial_ffmpeg" or "ffmpeg".
# OE won't let us build ffmpeg unless LICENSE_FLAGS_ACCEPTED contains "commercial" or "commercial_ffmpeg" or "ffmpeg".
RDEPENDS:${PN}:remove = "${@bb.utils.contains('ROS_WORLD_SKIP_GROUPS', 'ffmpeg', '${ROS_SUPERFLORE_GENERATED_WORLD_PACKAGES_DEPENDING_ON_FFMPEG}', '', d)}"

ROS_SUPERFLORE_GENERATED_WORLD_PACKAGES_DEPENDING_ON_FFMPEG = " \
Expand Down Expand Up @@ -1253,7 +1253,7 @@ ROS_SUPERFLORE_GENERATED_WORLD_PACKAGES_DEPENDING_ON_FFMPEG = " \
web-video-server \
"

# OE won't let us build x264 (and ffmpeg which depends on it) unless LICENSE_FLAGS_WHITELIST contains "commercial" or "commercial_x264" or "x264".
# OE won't let us build x264 (and ffmpeg which depends on it) unless LICENSE_FLAGS_ACCEPTED contains "commercial" or "commercial_x264" or "x264".
RDEPENDS:${PN}:remove = "${@bb.utils.contains('ROS_WORLD_SKIP_GROUPS', 'x264', '${ROS_SUPERFLORE_GENERATED_WORLD_PACKAGES_DEPENDING_ON_X264}', '', d)}"

ROS_SUPERFLORE_GENERATED_WORLD_PACKAGES_DEPENDING_ON_X264 = " \
Expand Down Expand Up @@ -1311,7 +1311,7 @@ ROS_SUPERFLORE_GENERATED_WORLD_PACKAGES_DEPENDING_ON_QT5_WIDGETS = " \
turtlesim-dash-tutorial \
"

# OE won't let us build gstreamer1.0-plugins-ugly unless LICENSE_FLAGS_WHITELIST contains "commercial".
# OE won't let us build gstreamer1.0-plugins-ugly unless LICENSE_FLAGS_ACCEPTED contains "commercial".
RDEPENDS:${PN}:remove = "${@bb.utils.contains('ROS_WORLD_SKIP_GROUPS', 'gst-ugly', '${ROS_SUPERFLORE_GENERATED_WORLD_PACKAGES_DEPENDING_ON_GSTREAMER1.0_PLUGINS_UGLY}', '', d)}"

ROS_SUPERFLORE_GENERATED_WORLD_PACKAGES_DEPENDING_ON_GSTREAMER1.0_PLUGINS_UGLY = " \
Expand Down
2 changes: 1 addition & 1 deletion meta-ros1-melodic/recipes-support/opencv/opencv_3.4.5.bb
Original file line number Diff line number Diff line change
Expand Up @@ -78,7 +78,7 @@ EXTRA_OECMAKE:append:x86 = " -DX86=ON"

PACKAGECONFIG ??= "python3 eigen jpeg png tiff v4l libv4l gstreamer samples tbb gphoto2 \
${@bb.utils.contains("DISTRO_FEATURES", "x11", "gtk", "", d)} \
${@bb.utils.contains("LICENSE_FLAGS_WHITELIST", "commercial", "libav", "", d)}"
${@bb.utils.contains("LICENSE_FLAGS_ACCEPTED", "commercial", "libav", "", d)}"

PACKAGECONFIG[amdblas] = "-DWITH_OPENCLAMDBLAS=ON,-DWITH_OPENCLAMDBLAS=OFF,libclamdblas,"
PACKAGECONFIG[amdfft] = "-DWITH_OPENCLAMDFFT=ON,-DWITH_OPENCLAMDFFT=OFF,libclamdfft,"
Expand Down
Loading

0 comments on commit 1bc2876

Please sign in to comment.