Skip to content

Commit

Permalink
Drop support for old Yocto release before kirkstone
Browse files Browse the repository at this point in the history
- Remove the support for dunfell, gatesgarth, hardknott and honister
- Update the references in the webkit-bleeding.inc
- Update the CI repo manifest.xml documents
- Update the CI test jobs (nanbield is the main one to stress now)

Signed-off-by: Pablo Saavedra <[email protected]>
  • Loading branch information
psaavedra committed Mar 9, 2024
1 parent 830404a commit 75e6c73
Show file tree
Hide file tree
Showing 16 changed files with 41 additions and 122 deletions.
21 changes: 0 additions & 21 deletions .github/manifest/manifest-dunfell.xml

This file was deleted.

2 changes: 0 additions & 2 deletions .github/manifest/manifest-kirkstone.xml
Original file line number Diff line number Diff line change
Expand Up @@ -14,7 +14,5 @@
<project remote="yocto" revision="kirkstone" name="poky" path="sources/poky"/>
<project remote="yocto" revision="kirkstone" name="meta-raspberrypi" path="sources/meta-raspberrypi"/>

<project remote="qt" revision="upstream/kirkstone" name="meta-qt5.git" path="sources/meta-qt5"/>

<project remote="igalia" revision="main" name="meta-webkit.git" path="sources/meta-webkit"/>
</manifest>
20 changes: 0 additions & 20 deletions .github/manifest/manifest-langdale.xml

This file was deleted.

File renamed without changes.
53 changes: 25 additions & 28 deletions .github/workflows/test-build.yml
Original file line number Diff line number Diff line change
Expand Up @@ -2,26 +2,6 @@ name: Build tests
on: [pull_request]
jobs:

dunfell-repo:
runs-on: self-hosted
if: "!contains(github.event.head_commit.message, 'ci skip')"
steps:
- uses: actions/checkout@v3
- uses: ./.github/actions/bitbake-repo
with:
repo_release: 'dunfell'

dunfell-raspberrypi3-mesa-weston-wpe-2-42:
runs-on: self-hosted
if: "!contains(github.event.head_commit.message, 'ci skip')"
steps:
- uses: actions/checkout@v3
- uses: ./.github/actions/bitbake-build
with:
bitbake_source: 'raspberrypi3-mesa-wpe-2-42 raspberrypi3-mesa poky layers.raspberrypi.clang.gstreamer.webkit conf_v1.wpe-2_42'
repo_release: 'dunfell'
needs: dunfell-repo

kirkstone-repo:
runs-on: self-hosted
if: "!contains(github.event.head_commit.message, 'ci skip')"
Expand Down Expand Up @@ -51,16 +31,23 @@ jobs:
with:
repo_release: 'nanbield'

nanbield-raspberrypi3-mesa-weston-wpe-2-42:
nanbield-matrix-wpe-2-42:
strategy:
fail-fast: false
matrix:
machine: ['raspberrypi3-mesa', 'raspberrypi4-64']
wpe_vers: ['2_42']
yocto_rel: ['nanbield']
continue-on-error: true
runs-on: self-hosted
if: "!contains(github.event.head_commit.message, 'ci skip')"
needs: nanbield-repo
steps:
- uses: actions/checkout@v3
- uses: ./.github/actions/bitbake-build
with:
bitbake_source: 'raspberrypi3-mesa-wpe-2-42 raspberrypi3-mesa poky layers.raspberrypi.webkit conf_v4.wpe-2_42'
repo_release: 'nanbield'
needs: nanbield-repo
bitbake_source: '${{ matrix.machine }}-wpe-${{ matrix.wpe_vers }} ${{ matrix.machine }} poky layers.raspberrypi.webkit conf_v3.wpe-${{ matrix.wpe_vers }}'
repo_release: ${{ matrix.yocto_rel }}

nanbield-raspberrypi3-mesa-weston-wpe-qt:
runs-on: self-hosted
Expand Down Expand Up @@ -108,13 +95,23 @@ jobs:
repo_release: 'nanbield'
needs: nanbield-repo

nanbield-raspberrypi4-64-weston-wpe-2-42:
scarthgap-repo:
runs-on: self-hosted
if: "!contains(github.event.head_commit.message, 'ci skip')"
steps:
- uses: actions/checkout@v3
- uses: ./.github/actions/bitbake-repo
with:
repo_release: 'scarthgap'

scarthgap-raspberrypi3-mesa-weston-wpe-2-42:
runs-on: self-hosted
if: "!contains(github.event.head_commit.message, 'ci skip')"
steps:
- uses: actions/checkout@v3
- uses: ./.github/actions/bitbake-build
with:
bitbake_source: 'raspberrypi4-64-wpe-2-42 raspberrypi4-64 poky layers.raspberrypi.webkit conf_v4.wpe-2_42'
repo_release: 'nanbield'
needs: nanbield-repo
bitbake_source: 'raspberrypi3-mesa-wpe-2-42 raspberrypi3-mesa poky layers.raspberrypi.webkit conf_v4.wpe-2_42'
repo_release: 'scarthgap'
needs: scarthgap-repo

6 changes: 0 additions & 6 deletions README.md
Original file line number Diff line number Diff line change
Expand Up @@ -20,12 +20,6 @@ This layer optionally depends on:
branch: 5.12
revision: HEAD

You may also need meta-clang for the case of Yocto Dunfell and WebnKit 2.42:

URI: https://github.com/kraj/meta-clang.git
branch: dunfell
revision: HEAD

If meta-qt5 is present, this layer will provide an opt-in Qt5 API as an
alternative to other Qt5 web-engines such as QtWebKit and QtWebEngine.

Expand Down
2 changes: 1 addition & 1 deletion conf/layer.conf
Original file line number Diff line number Diff line change
Expand Up @@ -17,4 +17,4 @@ BBFILE_PRIORITY_webkit = "7"
BB_DANGLINGAPPENDS_WARNONLY = "true"

# Support from the current actively maintained LTS Yocto release
LAYERSERIES_COMPAT_webkit = "dunfell gatesgarth hardknott honister kirkstone langdale mickledore nanbield"
LAYERSERIES_COMPAT_webkit = "kirkstone langdale mickledore nanbield"
4 changes: 0 additions & 4 deletions recipes-browser/cog/cog-meson.inc
Original file line number Diff line number Diff line change
Expand Up @@ -8,10 +8,6 @@ PACKAGECONFIG[soup2] = "-Dsoup2=enabled,-Dsoup2=disabled,libsoup-2.4"
PACKAGECONFIG[weston-direct-display] = "-Dwayland_weston_direct_display=true,-Dwayland_weston_direct_display=false,weston"
PACKAGECONFIG[wl] = ",,wpebackend-fdo"

# libsoup-3 is not available before Poky kirkstone.
# http://git.yoctoproject.org/cgit/cgit.cgi/poky/commit/meta/recipes-support/libsoup/libsoup_3.0.1.bb?id=de296e2b2be876ca5cf2af309b710111e2b2581e
PACKAGECONFIG:append = " ${@bb.utils.contains_any('LAYERSERIES_CORENAMES', 'dunfell gatesgarth hardknott honister', 'soup2', '', d)}"

# possible platforms: drm, headless, wayland (COG_PLATFORM_WL)
python __anonymous() {
packageconfig = (d.getVar("PACKAGECONFIG") or "").split()
Expand Down
2 changes: 1 addition & 1 deletion recipes-browser/cog/cog.inc
Original file line number Diff line number Diff line change
Expand Up @@ -17,7 +17,7 @@ SRC_URI = "https://wpewebkit.org/releases/${P}.tar.xz"
DEPENDS += "\
${@bb.utils.contains('PACKAGECONFIG', 'webkitgtk', 'webkitgtk', 'wpewebkit', d)} \
${@bb.utils.contains('PACKAGECONFIG', 'fdo', 'wayland', '', d)} \
${@bb.utils.contains_any('LAYERSERIES_CORENAMES', 'dunfell gatesgarth hardknott honister', 'libsoup-2.4', 'libsoup', d)} \
libsoup \
glib-2.0 wayland-native wayland-protocols \
libxkbcommon \
"
Expand Down
3 changes: 0 additions & 3 deletions recipes-browser/libwpe/libwpe-pkg-dunfell.inc

This file was deleted.

2 changes: 1 addition & 1 deletion recipes-browser/libwpe/libwpe.inc
Original file line number Diff line number Diff line change
Expand Up @@ -13,7 +13,7 @@ PROVIDES += "virtual/libwpe"
# Workaround build issue with RPi userland EGL libraries.
CFLAGS:append:rpi = " ${@bb.utils.contains('MACHINE_FEATURES', 'vc4graphics', '', '-D_GNU_SOURCE', d)}"

inherit features_check pkgconfig ${@bb.utils.contains_any("LAYERSERIES_CORENAMES", 'dunfell', 'cmake', 'meson', d)}
inherit features_check pkgconfig meson

REQUIRED_DISTRO_FEATURES = "opengl"

2 changes: 1 addition & 1 deletion recipes-browser/libwpe/libwpe_1.14.1.bb
Original file line number Diff line number Diff line change
@@ -1,5 +1,5 @@
require libwpe.inc
require ${@bb.utils.contains_any("LAYERSERIES_CORENAMES", 'dunfell', 'libwpe-pkg-dunfell.inc', 'libwpe-pkg.inc', d)}
require libwpe-pkg.inc
require conf/include/devupstream.inc

SRC_URI[sha256sum] = "b1d0cdcf0f8dbb494e65b0f7913e357106da9a0d57f4fbb7b9d1238a6dbe9ade"
Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -33,7 +33,7 @@ RDEPENDS:packagegroup-wpewebkit-depends = "\

RDEPENDS:packagegroup-wpewebkit-depends-sys-extended = "\
curl \
${@bb.utils.contains_any('LAYERSERIES_CORENAMES', 'dunfell', 'dhcp-client', 'dhcpcd', d)} \
dhcpcd \
hdparm \
libaio \
lzo \
Expand Down Expand Up @@ -134,7 +134,7 @@ RDEPENDS:packagegroup-wpewebkit-depends-core = "\
sqlite3 \
zlib \
libpng \
${@bb.utils.contains_any('LAYERSERIES_CORENAMES', 'dunfell gatesgarth hardknott honister', 'libsoup-2.4', 'libsoup', d)} \
libsoup \
libwebp \
libxml2 \
libxslt \
Expand Down Expand Up @@ -200,7 +200,7 @@ RDEPENDS:packagegroup-wpewebkit-depends-runtime-add:append:libc-glibc = "\
"

RDEPENDS:packagegroup-wpewebkit-depends-alternative = " \
${@bb.utils.contains_any('LAYERSERIES_CORENAMES', 'dunfell gatesgarth hardknott honister kirkstone', '', 'flite', d)} \
${@bb.utils.contains_any('LAYERSERIES_CORENAMES', 'kirkstone', '', 'flite', d)} \
geoclue \
libavif \
libevent \
Expand Down Expand Up @@ -229,7 +229,7 @@ RDEPENDS:packagegroup-wpewebkit-depends-video = " \
gstreamer1.0-plugins-base-audioconvert \
gstreamer1.0-plugins-base-audioresample \
gstreamer1.0-plugins-base-gio \
${@bb.utils.contains_any('LAYERSERIES_CORENAMES', 'dunfell gatesgarth hardknott honister kirkstone langdale', 'gstreamer1.0-plugins-base-videoconvert gstreamer1.0-plugins-base-videoscale', 'gstreamer1.0-plugins-base-videoconvertscale', d)} \
${@bb.utils.contains_any('LAYERSERIES_CORENAMES', 'kirkstone langdale', 'gstreamer1.0-plugins-base-videoconvert gstreamer1.0-plugins-base-videoscale', 'gstreamer1.0-plugins-base-videoconvertscale', d)} \
gstreamer1.0-plugins-base-volume \
gstreamer1.0-plugins-base-typefindfunctions \
gstreamer1.0-plugins-good-audiofx \
Expand All @@ -238,7 +238,6 @@ RDEPENDS:packagegroup-wpewebkit-depends-video = " \
gstreamer1.0-plugins-good-avi \
gstreamer1.0-plugins-good-deinterlace \
gstreamer1.0-plugins-good-interleave \
${@bb.utils.contains_any('LAYERSERIES_CORENAMES', 'dunfell', 'gstreamer1.0-plugins-bad-dashdemux', 'gstreamer1.0-plugins-bad-dash', d)} \
gstreamer1.0-plugins-bad-mpegtsdemux \
gstreamer1.0-plugins-bad-smoothstreaming \
gstreamer1.0-plugins-bad-videoparsersbad \
Expand Down
16 changes: 3 additions & 13 deletions recipes-browser/webkitgtk/webkitgtk_2.42.5.bb
Original file line number Diff line number Diff line change
Expand Up @@ -2,18 +2,13 @@ SUMMARY = "WebKit web rendering engine for the GTK+ platform"
HOMEPAGE = "http://www.webkitgtk.org/"
BUGTRACKER = "http://bugs.webkit.org/"

LICENSE = "BSD-2-Clause & ${@bb.utils.contains_any('LAYERSERIES_CORENAMES', 'dunfell gatesgarth hardknott honister', 'LGPL-2.0', 'LGPL-2.0-or-later', d)}"
LICENSE = "BSD-2-Clause & LGPL-2.0-or-later"
LIC_FILES_CHKSUM = "file://Source/JavaScriptCore/COPYING.LIB;md5=d0c6d6397a5d84286dda758da57bd691 \
file://Source/WebCore/LICENSE-APPLE;md5=4646f90082c40bcf298c285f8bab0b12 \
file://Source/WebCore/LICENSE-LGPL-2;md5=36357ffde2b64ae177b2494445b79d21 \
file://Source/WebCore/LICENSE-LGPL-2.1;md5=a778a33ef338abbaf8b8a7c36b6eec80 \
"

# WebKit 2.42 requires GCC>=10 (not provided in dunfell) or Clang>=10
# (provided by meta-clang in dunfell)
TOOLCHAIN = "${@bb.utils.contains_any("LAYERSERIES_CORENAMES", 'dunfell', 'clang', 'gcc', d)}"
LIBCPLUSPLUS = "${@bb.utils.contains_any("LAYERSERIES_CORENAMES", 'dunfell', '--stdlib=libc++', '', d)}"

# you need harfbuzz with icu enabled, you can add this to your config:
# PACKAGECONFIG:append:pn-harfbuzz = " icu"
DEPENDS = "zlib libsoup-2.4 curl libxml2 cairo libxslt libidn \
Expand All @@ -23,7 +18,7 @@ DEPENDS = "zlib libsoup-2.4 curl libxml2 cairo libxslt libidn \
sqlite3 libgcrypt \
unifdef-native \
libavif \
${@bb.utils.contains_any('LAYERSERIES_CORENAMES', 'dunfell gatesgarth hardknott honister', 'libsoup-2.4', 'libsoup', d)} \
libsoup \
"

FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"
Expand Down Expand Up @@ -58,7 +53,7 @@ PACKAGECONFIG ??= " ${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'x11', '', d)
enchant \
gbm \
jit \
${@bb.utils.contains_any('LAYERSERIES_CORENAMES', 'dunfell gatesgarth hardknott honister', '', 'jpegxl', d)} \
jpegxl \
libsecret \
openjpeg \
video \
Expand Down Expand Up @@ -95,14 +90,9 @@ EXTRA_OECMAKE = " \
-DENABLE_INTROSPECTION=OFF \
-DENABLE_GTKDOC=OFF \
-DENABLE_MINIBROWSER=ON \
${@bb.utils.contains_any("LAYERSERIES_CORENAMES", 'dunfell gatesgarth', '-DUSE_GSTREAMER_TRANSCODER=OFF', '', d)} \
-G Ninja \
"

# libsoup-3 is not available before Poky kirkstone.
# http://git.yoctoproject.org/cgit/cgit.cgi/poky/commit/meta/recipes-support/libsoup/libsoup_3.0.1.bb?id=de296e2b2be876ca5cf2af309b710111e2b2581e
PACKAGECONFIG:append = " ${@bb.utils.contains_any('LAYERSERIES_CORENAMES', 'dunfell gatesgarth hardknott honister', 'soup2', '', d)}"

# Javascript JIT is not supported on ppc/arm < v6/RISCV/mips64
PACKAGECONFIG:remove:powerpc = "jit"
PACKAGECONFIG:remove:powerpc64 = "jit"
Expand Down
16 changes: 5 additions & 11 deletions recipes-browser/wpewebkit/wpewebkit.inc
Original file line number Diff line number Diff line change
Expand Up @@ -3,11 +3,11 @@ SUMMARY = "WPE WebKit port pairs the WebKit engine with OpenGL-ES (OpenGL for Em
It is designed with hardware acceleration in mind, relying on EGL, and OpenGL ES."
HOMEPAGE = "https://trac.webkit.org/wiki/WPE"
BUGTRACKER = "https://bugs.webkit.org/"
LICENSE = "BSD-2-Clause & ${@bb.utils.contains_any('LAYERSERIES_CORENAMES', 'dunfell gatesgarth hardknott honister', 'LGPL-2.0', 'LGPL-2.0-or-later', d)}"
LICENSE = "BSD-2-Clause & LGPL-2.0-or-later"
LIC_FILES_CHKSUM = "file://Source/WebCore/LICENSE-LGPL-2.1;md5=a778a33ef338abbaf8b8a7c36b6eec80 "

DEPENDS:append = " \
${@bb.utils.contains_any('LAYERSERIES_CORENAMES', 'dunfell gatesgarth hardknott honister', 'libsoup-2.4', 'libsoup', d)} \
libsoup \
bison-native gperf-native harfbuzz-native libxml2-native ccache-native ninja-native ruby-native cairo \
fontconfig freetype glib-2.0 harfbuzz icu jpeg pcre sqlite3 zlib libpng \
libwebp libxml2 libxslt virtual/egl virtual/libgles2 libepoxy libgcrypt \
Expand Down Expand Up @@ -60,13 +60,9 @@ export WK_USE_CCACHE="NO"
PACKAGECONFIG ??= "jit dfg-jit mediasource mediastream video webaudio webcrypto woff2 gst_gl \
remote-inspector openjpeg unified-builds service-worker \
${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'journald', '' ,d)} \
avif gbm speech-synthesis \
avif gbm speech-synthesis jpegxl \
"

# libsoup-3 is not available before Poky kirkstone.
# http://git.yoctoproject.org/cgit/cgit.cgi/poky/commit/meta/recipes-support/libsoup/libsoup_3.0.1.bb?id=de296e2b2be876ca5cf2af309b710111e2b2581e
PACKAGECONFIG:append = " ${@bb.utils.contains_any('LAYERSERIES_CORENAMES', 'dunfell gatesgarth hardknott honister', 'soup2', '', d)}"

PACKAGECONFIG[reduce-size] = "-DCMAKE_BUILD_TYPE=MinSizeRel,-DCMAKE_BUILD_TYPE=Release,,"
# WPE features
PACKAGECONFIG[accessibility] = "-DENABLE_ACCESSIBILITY=ON,-DENABLE_ACCESSIBILITY=OFF,atk at-spi2-atk"
Expand All @@ -83,11 +79,9 @@ PACKAGECONFIG[gbm] = "-DUSE_GBM=ON,-DUSE_GBM=OFF,libdrm"
PACKAGECONFIG[geolocation] = "-DENABLE_GEOLOCATION=ON,-DENABLE_GEOLOCATION=OFF,geoclue"
PACKAGECONFIG[gpu-process] = "-DENABLE_GPU_PROCESS=ON,-DENABLE_GPU_PROCESS=OFF,"
PACKAGECONFIG[gst_gl] = "-DUSE_GSTREAMER_GL=ON,-DUSE_GSTREAMER_GL=OFF,gstreamer1.0-plugins-base"
PACKAGECONFIG[introspection] = "-DENABLE_INTROSPECTION=ON,-DENABLE_INTROSPECTION=OFF, gobject-introspection-native"
PACKAGECONFIG[jit] = "-DENABLE_JIT=ON,-DENABLE_JIT=OFF,"
# jpegxl: Added in 2.40+
PACKAGECONFIG[jpegxl] = "-DUSE_JPEGXL=ON,-DUSE_JPEGXL=OFF,libjxl"
PACKAGECONFIG:append = " ${@bb.utils.contains_any('LAYERSERIES_CORENAMES', 'dunfell gatesgarth hardknott honister', '', 'jpegxl', d)}"
PACKAGECONFIG[introspection] = "-DENABLE_INTROSPECTION=ON,-DENABLE_INTROSPECTION=OFF, gobject-introspection-native"
PACKAGECONFIG[journald] = "-DENABLE_JOURNALD_LOG=ON,-DENABLE_JOURNALD_LOG=OFF,"
PACKAGECONFIG[lbse] = "-DENABLE_LAYER_BASED_SVG_ENGINE=ON,-DENABLE_LAYER_BASED_SVG_ENGINE=OFF, "
PACKAGECONFIG[lcms] = "-DUSE_LCMS=ON,-DUSE_LCMS=OFF,"
Expand Down Expand Up @@ -164,7 +158,7 @@ ARM_INSTRUCTION_SET:armv7r = "thumb"
ARM_INSTRUCTION_SET:armv7m = "thumb"
ARM_INSTRUCTION_SET:armv7ve = "thumb"

GSTVIDEOCONVERTSCALEPLUGIN = "${@bb.utils.contains_any('LAYERSERIES_CORENAMES', 'dunfell gatesgarth hardknott honister kirkstone langdale', 'gstreamer1.0-plugins-base-videoconvert gstreamer1.0-plugins-base-videoscale', 'gstreamer1.0-plugins-base-videoconvertscale', d)}"
GSTVIDEOCONVERTSCALEPLUGIN = "${@bb.utils.contains_any('LAYERSERIES_CORENAMES', 'kirkstone langdale', 'gstreamer1.0-plugins-base-videoconvert gstreamer1.0-plugins-base-videoscale', 'gstreamer1.0-plugins-base-videoconvertscale', d)}"

# Extra runtime depends
RDEPENDS:${PN} += " \
Expand Down
5 changes: 0 additions & 5 deletions recipes-browser/wpewebkit/wpewebkit_2.42.5.bb
Original file line number Diff line number Diff line change
Expand Up @@ -3,11 +3,6 @@ require conf/include/devupstream.inc

FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"

# WebKit 2.42 requires GCC>=10 (not provided in dunfell) or Clang>=10
# (provided by meta-clang in dunfell)
TOOLCHAIN = "${@bb.utils.contains_any("LAYERSERIES_CORENAMES", 'dunfell', 'clang', 'gcc', d)}"
LIBCPLUSPLUS = "${@bb.utils.contains_any("LAYERSERIES_CORENAMES", 'dunfell', '--stdlib=libc++', '', d)}"

SRC_URI = "https://wpewebkit.org/releases/${BPN}-${PV}.tar.xz;name=tarball \
file://0001-FELightningNEON.cpp-fails-to-build-NEON-fast-path-se_2.42.patch \
file://0002-Activate-HAVE_MISSING_STD_FILESYSTEM_PATH_CONSTRUCTO.patch \
Expand Down

0 comments on commit 75e6c73

Please sign in to comment.