Skip to content

Commit

Permalink
Bump-up Webkit related components to the latest stable versions
Browse files Browse the repository at this point in the history
- Update cog 0.17.90 to 0.18.2.

  * Release notes:

    * https://wpewebkit.org/release/cog-0.18.0.html
    * https://wpewebkit.org/release/cog-0.18.1.html
    * https://wpewebkit.org/release/cog-0.18.2.html

  * Remove cog old versions: 0.12, 0.14

- Remove libwpe old versions: 1.12

- Update wpebackend-fdo 1.14.1 to 1.14.2

  * Release notes:

    * https://wpewebkit.org/release/wpebackend-fdo-1.14.2.html

  * Remove wpebackend-fdo old versions: 1.10, 1.12

- Add webkitgtk recipe for version 2.42.4

  * Release notes:

    * https://webkitgtk.org/2023/9/15/webkitgtk2.42.0-released.html
    * https://webkitgtk.org/2023/9/27/webkitgtk2.42.1-released.html
    * https://webkitgtk.org/2023/11/10/webkitgtk2.42.2-released.html
    * https://webkitgtk.org/2023/12/05/webkitgtk2.42.3-released.html
    * https://webkitgtk.org/2023/12/15/webkitgtk2.42.4-released.html

  * Remove webkitgtk old versions: 2.38, 2.40

- Add wpewebkit recipe for version 2.42.4

  * Release notes:

    * https://wpewebkit.org/release/wpewebkit-2.42.0.html
    * https://wpewebkit.org/release/wpewebkit-2.42.1.html
    * https://wpewebkit.org/release/wpewebkit-2.42.2.html
    * https://wpewebkit.org/release/wpewebkit-2.42.3.html
    * https://wpewebkit.org/release/wpewebkit-2.42.4.html

  * Remove wpewebkit old versions: 2.36, 2.38

- Update presets for wpe-2.40, remove presets for wpe-2.36 and add
  presets for wpe-2.42

- Update the references in the webkit-bleeding.inc

- Update the CI test jobs (2.42 is the main target to stress now)

Credits to Wouter Vanhauwaert for the initial work done in the Pull
Requests #487 [1].

[1] #487

Signed-off-by: Pablo Saavedra <[email protected]>
Suggested-by: Wouter Vanhauwaert <[email protected]>
  • Loading branch information
psaavedra committed Jan 25, 2024
1 parent 2e250ca commit e2819a4
Show file tree
Hide file tree
Showing 28 changed files with 420 additions and 405 deletions.
24 changes: 12 additions & 12 deletions .github/workflows/test-build.yml
Original file line number Diff line number Diff line change
Expand Up @@ -11,14 +11,14 @@ jobs:
with:
repo_release: 'dunfell'

dunfell-raspberrypi3-mesa-weston-wpe-2-38:
dunfell-raspberrypi3-mesa-weston-wpe-2-42:
runs-on: self-hosted
if: "!contains(github.event.head_commit.message, 'ci skip')"
steps:
- uses: actions/checkout@v3
- uses: ./.github/actions/bitbake-build
with:
bitbake_source: 'raspberrypi3-mesa-wpe-2-38 raspberrypi3-mesa poky layers.raspberrypi.gstreamer.webkit conf_v1.wpe-2_38'
bitbake_source: 'raspberrypi3-mesa-wpe-2-42 raspberrypi3-mesa poky layers.raspberrypi.gstreamer.webkit conf_v1.wpe-2_42'
repo_release: 'dunfell'
needs: dunfell-repo

Expand All @@ -31,14 +31,14 @@ jobs:
with:
repo_release: 'kirkstone'

kirkstone-raspberrypi3-mesa-weston-wpe-2-38:
kirkstone-raspberrypi3-mesa-weston-wpe-2-42:
runs-on: self-hosted
if: "!contains(github.event.head_commit.message, 'ci skip')"
steps:
- uses: actions/checkout@v3
- uses: ./.github/actions/bitbake-build
with:
bitbake_source: 'raspberrypi3-mesa-wpe-2-38 raspberrypi3-mesa poky layers.raspberrypi.webkit conf_v3.wpe-2_38'
bitbake_source: 'raspberrypi3-mesa-wpe-2-42 raspberrypi3-mesa poky layers.raspberrypi.webkit conf_v3.wpe-2_42'
repo_release: 'kirkstone'
needs: kirkstone-repo

Expand All @@ -51,14 +51,14 @@ jobs:
with:
repo_release: 'langdale'

langdale-raspberrypi3-mesa-weston-wpe-2-38:
langdale-raspberrypi3-mesa-weston-wpe-2-42:
runs-on: self-hosted
if: "!contains(github.event.head_commit.message, 'ci skip')"
steps:
- uses: actions/checkout@v3
- uses: ./.github/actions/bitbake-build
with:
bitbake_source: 'raspberrypi3-mesa-wpe-2-38 raspberrypi3-mesa poky layers.raspberrypi.webkit conf_v4.wpe-2_38'
bitbake_source: 'raspberrypi3-mesa-wpe-2-42 raspberrypi3-mesa poky layers.raspberrypi.webkit conf_v4.wpe-2_42'
repo_release: 'langdale'
needs: langdale-repo

Expand All @@ -69,7 +69,7 @@ jobs:
- uses: actions/checkout@v3
- uses: ./.github/actions/bitbake-build
with:
bitbake_source: 'raspberrypi3-mesa-wpe-qt raspberrypi3-mesa poky layers.raspberrypi.qt5.webkit conf_v4.wpe-2_38.qt'
bitbake_source: 'raspberrypi3-mesa-wpe-qt raspberrypi3-mesa poky layers.raspberrypi.qt5.webkit conf_v4.wpe-2_42.qt'
repo_release: 'langdale'
needs: langdale-repo

Expand All @@ -80,7 +80,7 @@ jobs:
- uses: actions/checkout@v3
- uses: ./.github/actions/bitbake-build
with:
bitbake_source: 'raspberrypi3-mesa-wpe-musl raspberrypi3-mesa poky layers.raspberrypi.webkit conf_v4.wpe-2_38'
bitbake_source: 'raspberrypi3-mesa-wpe-musl raspberrypi3-mesa poky layers.raspberrypi.webkit conf_v4.wpe-2_42'
bitbake_prefix: 'TCLIBC=musl'
repo_release: 'langdale'
needs: langdale-repo
Expand All @@ -96,14 +96,14 @@ jobs:
repo_release: 'langdale'
needs: langdale-repo

langdale-raspberrypi4-64-weston-wpe-2-38:
langdale-raspberrypi4-64-weston-wpe-2-42:
runs-on: self-hosted
if: "!contains(github.event.head_commit.message, 'ci skip')"
steps:
- uses: actions/checkout@v3
- uses: ./.github/actions/bitbake-build
with:
bitbake_source: 'raspberrypi4-64-wpe-2-38 raspberrypi4-64 poky layers.raspberrypi.webkit conf_v4.wpe-2_38'
bitbake_source: 'raspberrypi4-64-wpe-2-42 raspberrypi4-64 poky layers.raspberrypi.webkit conf_v4.wpe-2_42'
repo_release: 'langdale'
needs: langdale-repo

Expand All @@ -128,14 +128,14 @@ jobs:
with:
repo_release: 'mickledore'

mickledore-raspberrypi3-mesa-weston-wpe-2-38:
mickledore-raspberrypi3-mesa-weston-wpe-2-42:
runs-on: self-hosted
if: "!contains(github.event.head_commit.message, 'ci skip')"
steps:
- uses: actions/checkout@v3
- uses: ./.github/actions/bitbake-build
with:
bitbake_source: 'raspberrypi3-mesa-wpe-2-38 raspberrypi3-mesa poky layers.raspberrypi.webkit conf_v4.wpe-2_38'
bitbake_source: 'raspberrypi3-mesa-wpe-2-42 raspberrypi3-mesa poky layers.raspberrypi.webkit conf_v4.wpe-2_42'
repo_release: 'mickledore'
needs: mickledore-repo

Expand Down
4 changes: 2 additions & 2 deletions conf/include/webkit-bleeding.inc
Original file line number Diff line number Diff line change
Expand Up @@ -3,11 +3,11 @@
#
# require conf/include/webkit-bleeding.inc

PREFERRED_VERSION_cog = "0.17+httpsAUTOINC+%"
PREFERRED_VERSION_cog = "0.18+httpsAUTOINC+%"
PREFERRED_VERSION_libwpe = "1.14+httpsAUTOINC+%"
PREFERRED_VERSION_wpebackend-fdo = "devupstream+gitAUTOINC+%"
PREFERRED_VERSION_wpebackend-rdk = "1.20200213+gitAUTOINC+%"
PREFERRED_VERSION_wpewebkit = "2.40+httpsAUTOINC+%"
PREFERRED_VERSION_wpewebkit = "2.42+httpsAUTOINC+%"

SRCREV:class-devupstream:pn-cog = "${AUTOREV}"
SRCREV:class-devupstream:pn-libwpe = "${AUTOREV}"
Expand Down
7 changes: 0 additions & 7 deletions conf/templates/template/presets/wpe-2_36.conf

This file was deleted.

2 changes: 1 addition & 1 deletion conf/templates/template/presets/wpe-2_40.conf
Original file line number Diff line number Diff line change
@@ -1,6 +1,6 @@
PREFERRED_PROVIDER_virtual/wpebackend = "wpebackend-fdo"
PREFERRED_PROVIDER_virtual/libwpe = "libwpe"
PREFERRED_VERSION_cog = "0.17.%"
PREFERRED_VERSION_cog = "0.16.%"
PREFERRED_VERSION_libwpe = "1.14.%"
PREFERRED_VERSION_wpebackend-fdo = "1.14.%"
PREFERRED_VERSION_wpebackend-rdk = "1.20200213"
Expand Down
7 changes: 7 additions & 0 deletions conf/templates/template/presets/wpe-2_42.conf
Original file line number Diff line number Diff line change
@@ -0,0 +1,7 @@
PREFERRED_PROVIDER_virtual/wpebackend = "wpebackend-fdo"
PREFERRED_PROVIDER_virtual/libwpe = "libwpe"
PREFERRED_VERSION_cog = "0.18.%"
PREFERRED_VERSION_libwpe = "1.14.%"
PREFERRED_VERSION_wpebackend-fdo = "1.14.%"
PREFERRED_VERSION_wpebackend-rdk = "1.20200213"
PREFERRED_VERSION_wpewebkit = "2.42.%"
9 changes: 0 additions & 9 deletions recipes-browser/cog/cog-cmake.inc

This file was deleted.

1 change: 1 addition & 0 deletions recipes-browser/cog/cog.inc
Original file line number Diff line number Diff line change
Expand Up @@ -19,6 +19,7 @@ DEPENDS += "\
${@bb.utils.contains('PACKAGECONFIG', 'fdo', 'wayland', '', d)} \
${@bb.utils.contains_any('LAYERSERIES_CORENAMES', 'dunfell gatesgarth hardknott honister', 'libsoup-2.4', 'libsoup', d)} \
glib-2.0 wayland-native wayland-protocols \
libxkbcommon \
"

DEPENDS:append:class-target = " \
Expand Down
41 changes: 0 additions & 41 deletions recipes-browser/cog/cog/0001-Fix-missing-xkbcommon.h-include.patch

This file was deleted.

11 changes: 0 additions & 11 deletions recipes-browser/cog/cog_0.12.4.bb

This file was deleted.

16 changes: 0 additions & 16 deletions recipes-browser/cog/cog_0.14.1.bb

This file was deleted.

7 changes: 1 addition & 6 deletions recipes-browser/cog/cog_0.16.1.bb
Original file line number Diff line number Diff line change
@@ -1,12 +1,7 @@
require cog.inc
require cog-meson.inc

DEFAULT_PREFERENCE = "-1"

SRC_URI[sha256sum] = "37c5f14123b8dcf077839f6c60f0d721d2a91bb37829e796f420126e6b0d38b5"

# Required since https://github.com/Igalia/cog/commit/48dfac2ba637e223eeea1b289526d0f51e39ab88
DEPENDS:append = " libxkbcommon"

RDEPENDS:${PN} += "wpewebkit (>= 2.36)"
RDEPENDS:${PN} += "wpewebkit (< 2.38)"

18 changes: 0 additions & 18 deletions recipes-browser/cog/cog_0.17.90.bb

This file was deleted.

14 changes: 14 additions & 0 deletions recipes-browser/cog/cog_0.18.2.bb
Original file line number Diff line number Diff line change
@@ -0,0 +1,14 @@
require cog.inc
require cog-meson.inc
require conf/include/devupstream.inc

SRC_URI[sha256sum] = "3c4237cff6323b8c3eaf52c6f3f6415b898a22c0127c6c396c1eaa6eef46c279"

SRC_URI:class-devupstream = "git://github.com/Igalia/cog.git;protocol=https;branch=master"
# Cog 0.18.X branch was forked from the master branch in this commit
SRCREV:class-devupstream = "8e1acd3704e22904acc2fee0d4a2f5344257434c"

RDEPENDS:${PN} += "wpewebkit (>= 2.42)"

# Required for 0.17+
PACKAGECONFIG[soup2] = ",,libsoup-2.4"
6 changes: 0 additions & 6 deletions recipes-browser/libwpe/libwpe_1.12.3.bb

This file was deleted.

Loading

0 comments on commit e2819a4

Please sign in to comment.