Skip to content

Commit

Permalink
opendss-example: recipe added with the Messenger example of the DevGu…
Browse files Browse the repository at this point in the history
…ideExamples

Demo code of an OpenDDS application with CMake.

See:
  * https://github.com/OpenDDS/OpenDDS/tree/master/DevGuideExamples/DCPS/Messenger
  * https://opendds.readthedocs.io/en/latest-release/devguide/getting_started.html

TODO:
  * this example is not working when 'security' is added the the PACKAGECONFIG of OpenDDS
  * native version of this recipe is still misssing

Signed-off-by: Jan Vermaete <[email protected]>
  • Loading branch information
vermaete committed Oct 15, 2024
1 parent 2f65843 commit d5e431b
Show file tree
Hide file tree
Showing 3 changed files with 68 additions and 0 deletions.
6 changes: 6 additions & 0 deletions kas/opendds-example.yaml
Original file line number Diff line number Diff line change
@@ -0,0 +1,6 @@
header:
version: 1

local_conf_header:
opendds-example: |
IMAGE_INSTALL:append = " opendds-example"
23 changes: 23 additions & 0 deletions recipes-connectivity/opendds/opendds-example/readme.md
Original file line number Diff line number Diff line change
@@ -0,0 +1,23 @@
OpenDDS demo application
========================

See:

* https://github.com/OpenDDS/OpenDDS/tree/master/DevGuideExamples/DCPS/Messenger
* https://opendds.readthedocs.io/en/latest-release/devguide/getting_started.html

Run publisher
-------------

```
cd /usr/bin/opendds-example
./publisher -DCPSConfigFile rtps.ini
```

Run subscriber
--------------

```
cd /usr/bin/opendds-example
./subscriber -DCPSConfigFile rtps.ini
```
39 changes: 39 additions & 0 deletions recipes-connectivity/opendds/opendds-example_3.30.0.bb
Original file line number Diff line number Diff line change
@@ -0,0 +1,39 @@
SUMMARY = "OpenDDS example"
DESCRIPTION = "DevGuideExample DCPS Example from OpenDDS"
HOMEPAGE = "https://opendds.readthedocs.io/en/latest-release/devguide/getting_started.html"
LICENSE = "OpenDDS"
LIC_FILES_CHKSUM = "file://README.md;md5=3c38eddba8f9be09c2acc10026ca0ee1"

DEPENDS = "\
opendds \
opendds-native \
"

DDS_SRC_BRANCH = "branch-DDS-3.29"

SRC_URI = "\
git://github.com/OpenDDS/OpenDDS.git;protocol=https;branch=${DDS_SRC_BRANCH};subpath=DevGuideExamples/DCPS/Messenger \
file://readme.md \
"

SRCREV = "53414662d60f5e222aad9ca4383da0d856a577df"

S = "${WORKDIR}/Messenger"

inherit cmake

EXTRA_OECMAKE += "\
-DCMAKE_PREFIX_PATH=${WORKDIR}/recipe-sysroot/usr/ \
"

do_install() {
install -d ${D}${bindir}/${BPN}
install -m 0755 publisher ${D}${bindir}/${BPN}
install -m 0755 subscriber ${D}${bindir}/${BPN}
install -m 0644 rtps.ini ${D}${bindir}/${BPN}
install -m 0644 ${UNPACKDIR}/readme.md ${D}${bindir}/${BPN}
}

RDEPENDS:${PN} += "opendds"

INSANE_SKIP:${PN}-src += "buildpaths"

0 comments on commit d5e431b

Please sign in to comment.