Skip to content

Commit

Permalink
package/libstrophe: bump to version 0.12.0
Browse files Browse the repository at this point in the history
It requires a patch to fix a build issue, which has been submitted
upstream.

Signed-off-by: Michael Vetter <[email protected]>
Signed-off-by: Thomas Petazzoni <[email protected]>
  • Loading branch information
jubalh authored and tpetazzoni committed May 30, 2022
1 parent 727ca56 commit 75301bf
Show file tree
Hide file tree
Showing 3 changed files with 51 additions and 2 deletions.
49 changes: 49 additions & 0 deletions package/libstrophe/0001-fix-ssize_t.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,49 @@
From f31ef9c35c9bba831510777d551c4179295b208f Mon Sep 17 00:00:00 2001
From: Michael Vetter <[email protected]>
Date: Mon, 30 May 2022 14:47:44 +0200
Subject: [PATCH] Include sys/types.h for ssize_t
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit

When compiling on buildroot I get:
`src/tls.c:235:28: error: ‘ssize_t’ undeclared (first use in this
function); did you mean ‘size_t’? `

To have this POSIX type available we will need to include
`sys/types.h` on Linux. Unsure about other systems.

Upstream: https://github.com/strophe/libstrophe/pull/207
Signed-off-by: Michael Vetter <[email protected]>
---
src/rand.c | 1 +
src/tls.c | 4 ++++
2 files changed, 5 insertions(+)

diff --git a/src/rand.c b/src/rand.c
index 061e85ee..25e4614a 100644
--- a/src/rand.c
+++ b/src/rand.c
@@ -28,6 +28,7 @@
#if __GLIBC_PREREQ(2, 25)
#define USE_GETRANDOM
#include <sys/random.h>
+#include <sys/types.h>
#include <errno.h>
#endif
#endif
diff --git a/src/tls.c b/src/tls.c
index 17d85dda..54746baa 100644
--- a/src/tls.c
+++ b/src/tls.c
@@ -21,6 +21,10 @@
#include <stdarg.h>
#include <string.h>

+#if defined(__linux__)
+#include <sys/types.h>
+#endif
+
#include "strophe.h"

#include "common.h"
2 changes: 1 addition & 1 deletion package/libstrophe/libstrophe.hash
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# Locally calculated
sha256 feafee545403d26a44aa573d4adf327d6d07ad3f3466370634d22bbac5bd49ee libstrophe-0.11.0.tar.xz
sha256 8e44acb26018816f9856626bd5ff924a36cc612d2b3747ee634d626326b72df7 libstrophe-0.12.0.tar.xz
sha256 82476f36ffd5e895a176013c0812166ba7b7d99f3d536fc7f5ed2e33e9f74a08 MIT-LICENSE.txt
sha256 8ceb4b9ee5adedde47b31e975c1d90c73ad27b6b165a1dcd80c7c545eb65b903 GPL-LICENSE.txt
2 changes: 1 addition & 1 deletion package/libstrophe/libstrophe.mk
Original file line number Diff line number Diff line change
Expand Up @@ -4,7 +4,7 @@
#
################################################################################

LIBSTROPHE_VERSION = 0.11.0
LIBSTROPHE_VERSION = 0.12.0
LIBSTROPHE_SOURCE = libstrophe-$(LIBSTROPHE_VERSION).tar.xz
LIBSTROPHE_SITE = https://github.com/strophe/libstrophe/releases/download/$(LIBSTROPHE_VERSION)
LIBSTROPHE_DEPENDENCIES = host-pkgconf
Expand Down

0 comments on commit 75301bf

Please sign in to comment.