Skip to content

Commit

Permalink
universe/py3-py-cpuinfo: disable failing test on riscv64
Browse files Browse the repository at this point in the history
[ commit 473a14ff94cc2f5ffd3f681af360e3571448bc04 ]

upstream: workhorsy/py-cpuinfo#214
  • Loading branch information
ncopa authored and akodanev committed Apr 24, 2024
1 parent d34a85b commit 9bf30bd
Show file tree
Hide file tree
Showing 2 changed files with 19 additions and 0 deletions.
3 changes: 3 additions & 0 deletions universe/py3-py-cpuinfo/APKBUILD
Original file line number Diff line number Diff line change
Expand Up @@ -9,8 +9,10 @@ license="MIT"
depends="python3"
makedepends="py3-gpep517 py3-setuptools py3-wheel"
subpackages="$pkgname-pyc"
checkdepends="py3-pytest"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz
py-cpuinfo-loongarch64.patch
disable-test-from-proc-cpuinfo.patch
"
builddir="$srcdir"/$_pkgname-$pkgver

Expand All @@ -35,4 +37,5 @@ package() {
sha512sums="
c7711137d60ad52bcbef8738a70fb48ceaa69e1e1632d135d0ee95c282b02df6170c3dd88a1e14b3e9a386d3286a15ca9722fcfb596107da022161a7cf84509a py-cpuinfo-9.0.0.tar.gz
87e8d952c4aeee459f28abc75ce4a7fb6557053160b2d29afe28cfc05d922f4f550cc93757c4fbfd47b98e3f0447383a7a3609d982713970c482e2d4e490372e py-cpuinfo-loongarch64.patch
37b1835d2817d71abd769989feca95fcc2652e2b257165951f942ca6fa49ceee6b24c82e372db4b9087b665fd22d52ab83f5dec1b303386e8cd0d972d0f02481 disable-test-from-proc-cpuinfo.patch
"
16 changes: 16 additions & 0 deletions universe/py3-py-cpuinfo/disable-test-from-proc-cpuinfo.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,16 @@
This fails on riscv64:
https://github.com/workhorsy/py-cpuinfo/issues/214

diff --git a/tests/test_actual.py b/tests/test_actual.py
index fa0d934..960ac0d 100644
--- a/tests/test_actual.py
+++ b/tests/test_actual.py
@@ -71,7 +71,7 @@ class TestActual(unittest.TestCase):
self.assertEqual({}, cpuinfo._get_cpu_info_from_registry())
self.assertEqual({}, cpuinfo._get_cpu_info_from_cpufreq_info())
#self.assertTrue(len(cpuinfo._get_cpu_info_from_lscpu()) > 0)
- self.assertTrue(len(cpuinfo._get_cpu_info_from_proc_cpuinfo()) > 0)
+ #self.assertTrue(len(cpuinfo._get_cpu_info_from_proc_cpuinfo()) > 0)
self.assertEqual({}, cpuinfo._get_cpu_info_from_sysctl())
self.assertEqual({}, cpuinfo._get_cpu_info_from_kstat())
self.assertEqual({}, cpuinfo._get_cpu_info_from_dmesg())

0 comments on commit 9bf30bd

Please sign in to comment.