Update package.json #35
Annotations
16 warnings
build
The following actions uses node12 which is deprecated and will be forced to run on node16: actions/checkout@v2, actions/github-script@v3, actions/create-release@v1, actions/upload-release-asset@v1. For more info: https://github.blog/changelog/2023-06-13-github-actions-all-actions-will-run-on-node16-instead-of-node12-by-default/
|
build
The following actions use a deprecated Node.js version and will be forced to run on node20: actions/checkout@v2, actions/checkout@v3, actions/setup-node@v3, actions/cache@v3, gradle/gradle-build-action@v2, actions/github-script@v3, actions/create-release@v1, actions/upload-release-asset@v1. For more info: https://github.blog/changelog/2024-03-07-github-actions-all-actions-will-run-on-node20-instead-of-node16-by-default/
|
build:
src/background/controller/provider/controller.ts#L277
Prefer using an optional chain expression instead, as it's more concise and easier to read
|
build:
src/background/controller/provider/controller.ts#L367
This expression unnecessarily compares a boolean value to a boolean instead of using it directly
|
build:
src/background/controller/provider/controller.ts#L407
Prefer using an optional chain expression instead, as it's more concise and easier to read
|
build:
src/background/controller/provider/controller.ts#L407
This expression unnecessarily compares a boolean value to a boolean instead of using it directly
|
build:
src/background/controller/provider/rpcFlow.ts#L93
Prefer using an optional chain expression instead, as it's more concise and easier to read
|
build:
src/background/controller/provider/rpcFlow.ts#L145
Unexpected any. Specify a different type
|
build:
src/background/controller/provider/rpcFlow.ts#L182
Unexpected any. Specify a different type
|
build:
src/background/controller/wallet.ts#L207
Prefer using nullish coalescing operator (`??`) instead of a logical or (`||`), as it is a safer operator
|
build:
src/background/controller/wallet.ts#L586
Prefer using nullish coalescing operator (`??`) instead of a logical or (`||`), as it is a safer operator
|
build:
src/background/controller/wallet.ts#L619
Prefer using nullish coalescing operator (`??`) instead of a logical or (`||`), as it is a safer operator
|
build
The `set-output` command is deprecated and will be disabled soon. Please upgrade to using Environment Files. For more information see: https://github.blog/changelog/2022-10-11-github-actions-deprecating-save-state-and-set-output-commands/
|
build
The `set-output` command is deprecated and will be disabled soon. Please upgrade to using Environment Files. For more information see: https://github.blog/changelog/2022-10-11-github-actions-deprecating-save-state-and-set-output-commands/
|
build
The `set-output` command is deprecated and will be disabled soon. Please upgrade to using Environment Files. For more information see: https://github.blog/changelog/2022-10-11-github-actions-deprecating-save-state-and-set-output-commands/
|
build
The `set-output` command is deprecated and will be disabled soon. Please upgrade to using Environment Files. For more information see: https://github.blog/changelog/2022-10-11-github-actions-deprecating-save-state-and-set-output-commands/
|