Skip to content

Commit

Permalink
devel/electron{29,30,31,32,33}: remove USE_LDCONFIG and add BUNDLE_LIBS
Browse files Browse the repository at this point in the history
Shared libraries installed along with electron binary are for internal
use and not intended for public consumption.

Remove USE_LDCONFIG so as not to add the shared library directory to
search paths. Add BUNDLE_LIBS so that pkg(8) does not pick the shared
libraries up for packaging.

Bump port revisions for package change.

Related GitHub Issue: freebsd/pkg#2368

Reported by:	Vlad Biley <[email protected]>
  • Loading branch information
tagattie committed Dec 4, 2024
1 parent 5224b77 commit 9340b96
Show file tree
Hide file tree
Showing 5 changed files with 10 additions and 9 deletions.
4 changes: 2 additions & 2 deletions devel/electron29/Makefile
Original file line number Diff line number Diff line change
@@ -1,7 +1,7 @@
PORTNAME= electron
DISTVERSIONPREFIX= v
DISTVERSION= ${ELECTRON_VER:S/-beta./.b/}
PORTREVISION= 2
PORTREVISION= 3
CATEGORIES= devel
MASTER_SITES= https://github.com/tagattie/FreeBSD-Electron/releases/download/v29.2.0/:chromium \
https://commondatastorage.googleapis.com/chromium-nodejs/:chromium_node \
Expand Down Expand Up @@ -84,7 +84,6 @@ GH_TUPLE= nodejs:node:v${NODE_VER}:node \
EngFlow:reclient-configs:${ENGFLOW_RECLIENT_CONFIGS_VER}:reclient_configs
USE_GL= gbm gl glesv2
USE_GNOME= atk cairo gdkpixbuf2 gtk30 libxml2 libxslt pango
USE_LDCONFIG= ${DATADIR}
USE_XORG= x11 xcb xcomposite xcursor xdamage xext xfixes xi xrandr \
xrender xscrnsaver xtst

Expand All @@ -100,6 +99,7 @@ POST_BUILD_DIST_TARGETS=electron_dist_zip electron_chromedriver_zip \

DATADIR= ${PREFIX}/share/${PORTNAME}${PKGNAMESUFFIX}
BINARY_ALIAS= python3=${PYTHON_CMD}
BUNDLE_LIBS= yes

NO_WRKSUBDIR= yes
WRKSRC_SUBDIR= src
Expand Down
4 changes: 2 additions & 2 deletions devel/electron30/Makefile
Original file line number Diff line number Diff line change
@@ -1,7 +1,7 @@
PORTNAME= electron
DISTVERSIONPREFIX= v
DISTVERSION= ${ELECTRON_VER:S/-beta./.b/}
PORTREVISION= 4
PORTREVISION= 5
CATEGORIES= devel
MASTER_SITES= https://github.com/tagattie/FreeBSD-Electron/releases/download/v30.1.1/:chromium \
https://commondatastorage.googleapis.com/chromium-nodejs/:chromium_node \
Expand Down Expand Up @@ -85,7 +85,6 @@ GH_TUPLE= nodejs:node:v${NODE_VER}:node \
EngFlow:reclient-configs:${ENGFLOW_RECLIENT_CONFIGS_VER}:reclient_configs
USE_GL= gbm gl glesv2
USE_GNOME= atk cairo gdkpixbuf2 gtk30 libxml2 libxslt pango
USE_LDCONFIG= ${DATADIR}
USE_XORG= x11 xcb xcomposite xcursor xdamage xext xfixes xi xrandr \
xrender xscrnsaver xtst

Expand All @@ -101,6 +100,7 @@ POST_BUILD_DIST_TARGETS=electron_dist_zip electron_chromedriver_zip \

DATADIR= ${PREFIX}/share/${PORTNAME}${PKGNAMESUFFIX}
BINARY_ALIAS= python3=${PYTHON_CMD}
BUNDLE_LIBS= yes

NO_WRKSUBDIR= yes
WRKSRC_SUBDIR= src
Expand Down
4 changes: 2 additions & 2 deletions devel/electron31/Makefile
Original file line number Diff line number Diff line change
@@ -1,7 +1,7 @@
PORTNAME= electron
DISTVERSIONPREFIX= v
DISTVERSION= ${ELECTRON_VER:S/-beta./.b/}
PORTREVISION= 1
PORTREVISION= 2
PULSEMV= 16
PULSEV= ${PULSEMV}.1
CATEGORIES= devel
Expand Down Expand Up @@ -89,7 +89,6 @@ GH_TUPLE= nodejs:node:v${NODE_VER}:node \
EngFlow:reclient-configs:${ENGFLOW_RECLIENT_CONFIGS_VER}:reclient_configs
USE_GL= gbm gl glesv2
USE_GNOME= atk cairo gdkpixbuf2 gtk30 libxml2 libxslt pango
USE_LDCONFIG= ${DATADIR}
USE_XORG= x11 xcb xcomposite xcursor xdamage xext xfixes xi xrandr \
xrender xscrnsaver xtst

Expand All @@ -105,6 +104,7 @@ POST_BUILD_DIST_TARGETS=electron_dist_zip electron_chromedriver_zip \

DATADIR= ${PREFIX}/share/${PORTNAME}${PKGNAMESUFFIX}
BINARY_ALIAS= python3=${PYTHON_CMD}
BUNDLE_LIBS= yes

NO_WRKSUBDIR= yes
WRKSRC_SUBDIR= src
Expand Down
4 changes: 2 additions & 2 deletions devel/electron32/Makefile
Original file line number Diff line number Diff line change
@@ -1,7 +1,7 @@
PORTNAME= electron
DISTVERSIONPREFIX= v
DISTVERSION= ${ELECTRON_VER}
PORTREVISION= 1
PORTREVISION= 2
PULSEMV= 16
PULSEV= ${PULSEMV}.1
CATEGORIES= devel
Expand Down Expand Up @@ -86,7 +86,6 @@ GH_TUPLE= nodejs:node:v${NODE_VER}:node \
EngFlow:reclient-configs:${ENGFLOW_RECLIENT_CONFIGS_VER}:reclient_configs
USE_GL= gbm gl glesv2
USE_GNOME= atk cairo gdkpixbuf2 gtk30 libxml2 libxslt pango
USE_LDCONFIG= ${DATADIR}
USE_XORG= x11 xcb xcomposite xcursor xdamage xext xfixes xi xrandr \
xrender xscrnsaver xtst

Expand All @@ -102,6 +101,7 @@ POST_BUILD_DIST_TARGETS=electron_dist_zip electron_chromedriver_zip \

DATADIR= ${PREFIX}/share/${PORTNAME}${PKGNAMESUFFIX}
BINARY_ALIAS= python3=${PYTHON_CMD}
BUNDLE_LIBS= yes

NO_WRKSUBDIR= yes
WRKSRC_SUBDIR= src
Expand Down
3 changes: 2 additions & 1 deletion devel/electron33/Makefile
Original file line number Diff line number Diff line change
@@ -1,6 +1,7 @@
PORTNAME= electron
DISTVERSIONPREFIX= v
DISTVERSION= ${ELECTRON_VER}
PORTREVISION= 1
PULSEMV= 16
PULSEV= ${PULSEMV}.1
CATEGORIES= devel
Expand Down Expand Up @@ -85,7 +86,6 @@ GH_TUPLE= nodejs:node:v${NODE_VER}:node \
EngFlow:reclient-configs:${ENGFLOW_RECLIENT_CONFIGS_VER}:reclient_configs
USE_GL= gbm gl glesv2
USE_GNOME= atk cairo gdkpixbuf2 gtk30 libxml2 libxslt pango
USE_LDCONFIG= ${DATADIR}
USE_XORG= x11 xcb xcomposite xcursor xdamage xext xfixes xi xrandr \
xrender xscrnsaver xtst

Expand All @@ -101,6 +101,7 @@ POST_BUILD_DIST_TARGETS=electron_dist_zip electron_chromedriver_zip \

DATADIR= ${PREFIX}/share/${PORTNAME}${PKGNAMESUFFIX}
BINARY_ALIAS= python3=${PYTHON_CMD}
BUNDLE_LIBS= yes

NO_WRKSUBDIR= yes
WRKSRC_SUBDIR= src
Expand Down

0 comments on commit 9340b96

Please sign in to comment.