-
Notifications
You must be signed in to change notification settings - Fork 77
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
kde-apps/okular: Backport fixes by upstream request
See also: https://mail.kde.org/pipermail/distributions/2024-January/001476.html Signed-off-by: Andreas Sturmlechner <[email protected]>
- Loading branch information
Showing
3 changed files
with
55 additions
and
0 deletions.
There are no files selected for viewing
25 changes: 25 additions & 0 deletions
25
kde-apps/okular/files/okular-24.01.90-fix-compile-path.patch
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,25 @@ | ||
From 7aac8a4f9aa8f1c296f6f5c3e68d0404e3925913 Mon Sep 17 00:00:00 2001 | ||
From: Sune Vuorela <[email protected]> | ||
Date: Fri, 12 Jan 2024 09:43:16 +0100 | ||
Subject: [PATCH] Also fix compile path | ||
|
||
(cherry picked from commit 478f6f24fbde4657b7bd13dbc4a58512cbd6eb2a) | ||
--- | ||
CMakeLists.txt | 1 + | ||
1 file changed, 1 insertion(+) | ||
|
||
diff --git a/CMakeLists.txt b/CMakeLists.txt | ||
index 9cb9851731..0a56d74b5d 100644 | ||
--- a/CMakeLists.txt | ||
+++ b/CMakeLists.txt | ||
@@ -615,6 +615,7 @@ if (KF6Purpose_FOUND) | ||
endif() | ||
|
||
set_target_properties(okularpart PROPERTIES PREFIX "") | ||
+set_target_properties(okularpart PROPERTIES LIBRARY_OUTPUT_DIRECTORY ${CMAKE_LIBRARY_OUTPUT_DIRECTORY}/kf6/parts) | ||
|
||
if (Qt6TextToSpeech_FOUND) | ||
target_link_libraries(okularpart Qt6::TextToSpeech) | ||
-- | ||
GitLab | ||
|
28 changes: 28 additions & 0 deletions
28
kde-apps/okular/files/okular-24.01.90-fix-loading-okularpart.patch
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,28 @@ | ||
From f23a2448b00e1aa83158bfdb66a1f981afe61938 Mon Sep 17 00:00:00 2001 | ||
From: Nicolas Fella <[email protected]> | ||
Date: Fri, 12 Jan 2024 01:02:46 +0100 | ||
Subject: [PATCH] Fix loading okularpart | ||
|
||
Adapt to the new location | ||
|
||
(cherry picked from commit 53fb06d6b4a931b87364a87fcced459b5824b678) | ||
--- | ||
shell/shell.cpp | 2 +- | ||
1 file changed, 1 insertion(+), 1 deletion(-) | ||
|
||
diff --git a/shell/shell.cpp b/shell/shell.cpp | ||
index 0a006d5cad..9074a16037 100644 | ||
--- a/shell/shell.cpp | ||
+++ b/shell/shell.cpp | ||
@@ -201,7 +201,7 @@ Shell::Shell(const QString &serializedOptions) | ||
// name which is a bad idea usually.. but it's alright in this | ||
// case since our Part is made for this Shell | ||
|
||
- const auto result = KPluginFactory::loadFactory(KPluginMetaData(QStringLiteral("okularpart"))); | ||
+ const auto result = KPluginFactory::loadFactory(KPluginMetaData(QStringLiteral("kf6/parts/okularpart"))); | ||
|
||
if (!result) { | ||
// if we couldn't find our Part, we exit since the Shell by | ||
-- | ||
GitLab | ||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters