Skip to content

Commit

Permalink
x11-misc/xdg-java: new package, add 0.1.1, 9999
Browse files Browse the repository at this point in the history
Signed-off-by: IAHMCOL <[email protected]>
  • Loading branch information
IAHM-COL committed Jul 22, 2023
1 parent b90875d commit 6663b2e
Show file tree
Hide file tree
Showing 4 changed files with 105 additions and 0 deletions.
1 change: 1 addition & 0 deletions x11-misc/xdg-java/Manifest
Original file line number Diff line number Diff line change
@@ -0,0 +1 @@
DIST xdg-java-0.1.1-sources.tar.gz 19734 BLAKE2B 402eedd9d0c6e8fd2ddb138fcbd16b06d653af6e219f5ca91df73dce9cbbed3764e39e886a67b4290fd079c71a2b86b2be2a31cee368d12f2e022deeb8887612 SHA512 01f63339bc21a502693c803f38762e66fc0ad570acf0ba6fde17519d820e9f6b94183f30b265ab68467a7c37a9df65612aed3774b6b6f955113c2bac9f1f7077
14 changes: 14 additions & 0 deletions x11-misc/xdg-java/metadata.xml
Original file line number Diff line number Diff line change
@@ -0,0 +1,14 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<longdescription>
This is a Java API that provides an easy to use implementations of various Free Desktop specifications. Use the correct application specific configuration, data and cache directories. Safely read and write desktop entries without worrying about parsing and escaping.
</longdescription>
<maintainer type="project">
<email>[email protected]</email>
<name>Gentoo Science Project</name>
</maintainer>
<upstream>
<remote-id type="github">kothar/xdg-java</remote-id>
</upstream>
</pkgmetadata>
45 changes: 45 additions & 0 deletions x11-misc/xdg-java/xdg-java-0.1.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,45 @@
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

JAVA_PKG_IUSE="doc source test"
JAVA_TESTING_FRAMEWORKS="junit-4"

inherit java-pkg-2 java-pkg-simple

DESCRIPTION="Java bindings for various FreeDesktop.org standards"
HOMEPAGE="https://github.com/kothar/xdg-java"

if [[ ${PV} == 9999 ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/kothar/xdg-java.git"
S="${WORKDIR}/${P}"
MAVEN_ID="net.kothar:xdg-java:9999"
else
SRC_URI="
https://github.com/kothar/${PN}/archive/refs/tags/${PV}.tar.gz -> ${P}-sources.tar.gz
"
S="${WORKDIR}/${P}"
MAVEN_ID="net.kothar:xdg-java:0.1.1"
KEYWORDS="~amd64"
fi

LICENSE="LGPL-2.1"
SLOT="0"

DEPEND=">=virtual/jdk-1.8:*"

BDEPEND="
>=virtual/jdk-1.8:*
test? (
>=dev-java/junit-4.13.2:4
)
"

RDEPEND=">=virtual/jre-1.8:*"

JAVA_SRC_DIR="src/main/java"

JAVA_TEST_GENTOO_CLASSPATH="junit-4"
JAVA_TEST_SRC_DIR="src/test/java"
45 changes: 45 additions & 0 deletions x11-misc/xdg-java/xdg-java-9999.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,45 @@
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

JAVA_PKG_IUSE="doc source test"
JAVA_TESTING_FRAMEWORKS="junit-4"

inherit java-pkg-2 java-pkg-simple

DESCRIPTION="Java bindings for various FreeDesktop.org standards"
HOMEPAGE="https://github.com/kothar/xdg-java"

if [[ ${PV} == 9999 ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/kothar/xdg-java.git"
S="${WORKDIR}/${P}"
MAVEN_ID="net.kothar:xdg-java:9999"
else
SRC_URI="
https://github.com/kothar/${PN}/archive/refs/tags/${PV}.tar.gz -> ${P}-sources.tar.gz
"
S="${WORKDIR}/${P}"
MAVEN_ID="net.kothar:xdg-java:0.1.1"
KEYWORDS="~amd64"
fi

LICENSE="LGPL-2.1"
SLOT="0"

DEPEND=">=virtual/jdk-1.8:*"

BDEPEND="
>=virtual/jdk-1.8:*
test? (
>=dev-java/junit-4.13.2:4
)
"

RDEPEND=">=virtual/jre-1.8:*"

JAVA_SRC_DIR="src/main/java"

JAVA_TEST_GENTOO_CLASSPATH="junit-4"
JAVA_TEST_SRC_DIR="src/test/java"

0 comments on commit 6663b2e

Please sign in to comment.