Skip to content

Commit

Permalink
sci-physics/particle: new package, add 0.23.0, 9999
Browse files Browse the repository at this point in the history
Signed-off-by: Alexander Puck Neuwirth <[email protected]>
  • Loading branch information
APN-Pucky committed Jul 26, 2023
1 parent be5a768 commit 7c97d85
Show file tree
Hide file tree
Showing 4 changed files with 104 additions and 0 deletions.
1 change: 1 addition & 0 deletions sci-physics/particle/Manifest
Original file line number Diff line number Diff line change
@@ -0,0 +1 @@
DIST particle-0.23.0.tar.gz 313512 BLAKE2B 33a0dc1cf612af8242b5080d0862f3b1e587254b46fa90f235cd6edba3919594c5077733600dfe88ad0959be889271c301324789abf0511a7fbe588942086877 SHA512 582c42beade0b28f28f3ee9f83f6d8cc75558f8a9aa5fbe3679c7aa68af40bd04f374741211d6f214bb828c24a017a89b541f780739a36d61d85a2fd5e00b530
19 changes: 19 additions & 0 deletions sci-physics/particle/metadata.xml
Original file line number Diff line number Diff line change
@@ -0,0 +1,19 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="project">
<email>[email protected]</email>
<name>Gentoo Science Project</name>
</maintainer>
<maintainer type="person">
<email>[email protected]</email>
<name>Alexander Puck Neuwirth</name>
</maintainer>
<longdescription lang="en">
Particle provides a pythonic interface to the Particle Data Group (PDG) particle data tables and particle identification codes, with extended particle information and extra goodies.
</longdescription>
<upstream>
<remote-id type="pypi">particle</remote-id>
<remote-id type="github">scikit-hep/particle</remote-id>
</upstream>
</pkgmetadata>
42 changes: 42 additions & 0 deletions sci-physics/particle/particle-0.23.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,42 @@
EAPI=8

PYTHON_COMPAT=( python3_11 )
DISTUTILS_USE_PEP517=hatchling
inherit distutils-r1

DESCRIPTION="PDG particle data and identification codes"
HOMEPAGE="https://github.com/scikit-hep/particle"

LICENSE="BSD"
SLOT="0"

if [[ ${PV} == 9999 ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/scikit-hep/particle"
else
inherit pypi
KEYWORDS="~amd64"
fi

RDEPEND="
>=dev-python/attrs-19.2[${PYTHON_USEDEP}]
>=sci-physics/hepunits-2.0.0[${PYTHON_USEDEP}]
dev-python/deprecated[${PYTHON_USEDEP}]
test? (
>=dev-python/pytest-6.0.0[${PYTHON_USEDEP}]
dev-python/pandas[${PYTHON_USEDEP}]
dev-python/tabulate[${PYTHON_USEDEP}]
)
"
BDEPEND="${RDEPEND}"
distutils_enable_tests pytest

src_prepare() {
default

sed -i -e 's:--benchmark-disable::' pyproject.toml || die
}

python_test() {
epytest --ignore tests/particle/test_performance.py
}
42 changes: 42 additions & 0 deletions sci-physics/particle/particle-9999.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,42 @@
EAPI=8

PYTHON_COMPAT=( python3_11 )
DISTUTILS_USE_PEP517=hatchling
inherit distutils-r1

DESCRIPTION="PDG particle data and identification codes"
HOMEPAGE="https://github.com/scikit-hep/particle"

LICENSE="BSD"
SLOT="0"

if [[ ${PV} == 9999 ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/scikit-hep/particle"
else
inherit pypi
KEYWORDS="~amd64"
fi

RDEPEND="
>=dev-python/attrs-19.2[${PYTHON_USEDEP}]
>=sci-physics/hepunits-2.0.0[${PYTHON_USEDEP}]
dev-python/deprecated[${PYTHON_USEDEP}]
test? (
>=dev-python/pytest-6.0.0[${PYTHON_USEDEP}]
dev-python/pandas[${PYTHON_USEDEP}]
dev-python/tabulate[${PYTHON_USEDEP}]
)
"
BDEPEND="${RDEPEND}"
distutils_enable_tests pytest

src_prepare() {
default

sed -i -e 's:--benchmark-disable::' pyproject.toml || die
}

python_test() {
epytest --ignore tests/particle/test_performance.py
}

0 comments on commit 7c97d85

Please sign in to comment.