Skip to content

Commit

Permalink
dev-python/llvmlite: add 0.41.0
Browse files Browse the repository at this point in the history
Signed-off-by: Andrew Ammerlaan <[email protected]>
  • Loading branch information
Nowa-Ammerlaan committed Oct 24, 2023
1 parent 1d7cb19 commit 805fd61
Show file tree
Hide file tree
Showing 2 changed files with 58 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-python/llvmlite/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST llvmlite-0.39.1.gh.tar.gz 237119 BLAKE2B c2538994a6b9116d9a124ad8b8fff9c06d654bcdd345fb25251505b7577c6dffdfa56c9226250dbc2de6253cf6154523ec0d3cd849697a66cabf5b522c5e76ca SHA512 16b341300e4034aff4ce9553fec6b5923b9f4cb261c1ec0ee2cef6d87addcbebe8f4805dbc2fb30f357800fa029c3b6fc8ed62a5fdaad7c262e723c3b9c4ad32
DIST llvmlite-0.40.1.gh.tar.gz 261765 BLAKE2B f795fc7e0256333a6f6172788fb839b0b3fd304b654baaa58cae53d5e5e145f6e937fcb83ed096a3885c060a03fbf1d8546007ea7fafaa4028cd21b5aee19bd1 SHA512 b88d931cf252169a9246d8c935fe28ad509fe7da1f8b1842c4b4c40808c64b68d47a2387ed4664c0c0812b39cfbfc30ea4f9e702a7cd893c4c61a3596bc2e697
DIST llvmlite-0.41.0.gh.tar.gz 248547 BLAKE2B 3b5aa6b19e08d300384cedd123024d6c73368db255f2010cfbe4fa04e1e1f2d81e644db8b1c8540a5c1134d36c0fce333940c92f3ec984c239dc8c47537e8dca SHA512 bd84b754f07bfc82f9800e1e0a2bc965cfee0f726b4f06b21b8ca04a46c388bc4c423c4ed5f6e6b14562f5ff97e3f356022ad770ea1d351f0330277a4f350966
57 changes: 57 additions & 0 deletions dev-python/llvmlite/llvmlite-0.41.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,57 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

PYTHON_COMPAT=( python3_{10..12} )
DISTUTILS_USE_PEP517=setuptools
DISTUTILS_EXT=1
inherit distutils-r1 llvm

DESCRIPTION="Python wrapper around the llvm C++ library"
HOMEPAGE="https://llvmlite.pydata.org/"
SRC_URI="https://github.com/numba/llvmlite/archive/v${PV/_/}.tar.gz -> ${P/_/}.gh.tar.gz"
S="${WORKDIR}/${P/_/}"

LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~x86"
IUSE="examples"

LLVM_MAX_SLOT=14

RDEPEND="
sys-devel/llvm:${LLVM_MAX_SLOT}
sys-libs/zlib:0=
"
DEPEND="${RDEPEND}"

python_configure_all() {
# upstream's build system is just horrible, and they ignored the PR
# fixing it, so let's build the shared lib properly using implicit
# make rules

export LDLIBS=$(llvm-config --libs all)
export CXXFLAGS="$(llvm-config --cxxflags) -fPIC ${CXXFLAGS}"
export LDFLAGS="$(llvm-config --ldflags) ${LDFLAGS}"

local files=( ffi/*.cpp )
emake -f - <<EOF
ffi/libllvmlite.so: ${files[*]/.cpp/.o}
\$(CXX) -shared \$(CXXFLAGS) \$(LDFLAGS) -o \$@ \$^ \$(LDLIBS)
EOF

export LLVMLITE_SKIP_LLVM_VERSION_CHECK=1
}

python_test() {
"${EPYTHON}" runtests.py -v || die "Tests failed under ${EPYTHON}"
}

python_install_all() {
distutils-r1_python_install_all
if use examples; then
dodoc -r examples
docompress -x /usr/share/doc/${PF}/examples
fi
}

0 comments on commit 805fd61

Please sign in to comment.