Skip to content

Commit

Permalink
dev-java/scijava-optional: new package, add 1.0.1, 9999
Browse files Browse the repository at this point in the history
Signed-off-by: IAHMCOL <[email protected]>
Closes: #1206
Signed-off-by: Andrew Ammerlaan <[email protected]>
  • Loading branch information
IAHM-COL authored and Nowa-Ammerlaan committed Aug 17, 2023
1 parent 14eccb0 commit 9575704
Show file tree
Hide file tree
Showing 4 changed files with 100 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-java/scijava-optional/Manifest
Original file line number Diff line number Diff line change
@@ -0,0 +1 @@
DIST scijava-optional-1.0.1-sources.tar.gz 7659 BLAKE2B c5a99b5ffcd5c8a09cc40d360d31796002993352b581509bbb78d4464f0119313b743bdf94b22532bd5bcc3a8baf614273378031154588245805cc6bccf39de5 SHA512 e083586fb6015354bc7520bed04d4c7c745445e01ffb6ba86bb91505f65ba06dfb50cbcecf3971fcb9161c16a2e112af31e247edffae973bf310e13bded99e89
11 changes: 11 additions & 0 deletions dev-java/scijava-optional/metadata.xml
Original file line number Diff line number Diff line change
@@ -0,0 +1,11 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="project">
<email>[email protected]</email>
<name>Gentoo Science Project</name>
</maintainer>
<upstream>
<remote-id type="github">scijava/scijava-optional</remote-id>
</upstream>
</pkgmetadata>
44 changes: 44 additions & 0 deletions dev-java/scijava-optional/scijava-optional-1.0.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,44 @@
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

JAVA_PKG_IUSE="doc source test"
JAVA_TESTING_FRAMEWORKS="junit-4"

inherit java-pkg-2 java-pkg-simple

DESCRIPTION="Helpers for emulating named and default arguments"
HOMEPAGE="https://github.com/scijava/scijava-optional"

if [[ ${PV} == 9999 ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/scijava/scijava-optional.git"
S="${WORKDIR}/${P}"
MAVEN_ID="org.scijava:scijava-optional:9999"
else
SRC_URI="
https://github.com/scijava/${PN}/archive/refs/tags/${P}.tar.gz -> ${P}-sources.tar.gz
"
S="${WORKDIR}/${PN}-${P}"
MAVEN_ID="org.scijava:scijava-optional:1.0.2"
KEYWORDS="~amd64"
fi

LICENSE="BSD-2"
SLOT="0"

BDEPEND="
>=virtual/jdk-1.8:*
test? (
>=dev-java/junit-4.13.2:4
)
"

RDEPEND=">=virtual/jre-1.8:*"

JAVA_SRC_DIR="src/main/java"
JAVA_MAIN_CLASS=""

JAVA_TEST_GENTOO_CLASSPATH="junit-4"
JAVA_TEST_SRC_DIR="src/test/java"
44 changes: 44 additions & 0 deletions dev-java/scijava-optional/scijava-optional-9999.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,44 @@
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

JAVA_PKG_IUSE="doc source test"
JAVA_TESTING_FRAMEWORKS="junit-4"

inherit java-pkg-2 java-pkg-simple

DESCRIPTION="Helpers for emulating named and default arguments"
HOMEPAGE="https://github.com/scijava/scijava-optional"

if [[ ${PV} == 9999 ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/scijava/scijava-optional.git"
S="${WORKDIR}/${P}"
MAVEN_ID="org.scijava:scijava-optional:9999"
else
SRC_URI="
https://github.com/scijava/${PN}/archive/refs/tags/${P}.tar.gz -> ${P}-sources.tar.gz
"
S="${WORKDIR}/${PN}-${P}"
MAVEN_ID="org.scijava:scijava-optional:1.0.2"
KEYWORDS="~amd64"
fi

LICENSE="BSD-2"
SLOT="0"

BDEPEND="
>=virtual/jdk-1.8:*
test? (
>=dev-java/junit-4.13.2:4
)
"

RDEPEND=">=virtual/jre-1.8:*"

JAVA_SRC_DIR="src/main/java"
JAVA_MAIN_CLASS=""

JAVA_TEST_GENTOO_CLASSPATH="junit-4"
JAVA_TEST_SRC_DIR="src/test/java"

0 comments on commit 9575704

Please sign in to comment.