Skip to content

Commit

Permalink
dev-java/scijava-table: new package, add 1.0.2, 9999
Browse files Browse the repository at this point in the history
Signed-off-by: IAHMCOL <[email protected]>
  • Loading branch information
IAHM-COL committed Jul 23, 2023
1 parent b90875d commit b3ed66a
Show file tree
Hide file tree
Showing 4 changed files with 120 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-java/scijava-table/Manifest
Original file line number Diff line number Diff line change
@@ -0,0 +1 @@
DIST scijava-table-1.0.2-sources.tar.gz 37037 BLAKE2B 61a6b2da5cb355e00feb49895ae1a9a978ba50ee75e60c4f74d1490d1c167ca3a19452621ba25afccc975f4fbf3636ae09c0d25019e04980c4247fc18d859951 SHA512 17bbb1f798f7ee718fd2fbd9f9c81419cb5054b40d82cac9fa3b9f882e9ba46b410979038d8031d6f6dea53902f0865e68d59e55e1b02ab717da40aed5726b70
11 changes: 11 additions & 0 deletions dev-java/scijava-table/metadata.xml
Original file line number Diff line number Diff line change
@@ -0,0 +1,11 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="project">
<email>[email protected]</email>
<name>Gentoo Science Project</name>
</maintainer>
<upstream>
<remote-id type="github">scijava/scijava-table</remote-id>
</upstream>
</pkgmetadata>
54 changes: 54 additions & 0 deletions dev-java/scijava-table/scijava-table-1.0.2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,54 @@
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

JAVA_PKG_IUSE="doc source test"
JAVA_TESTING_FRAMEWORKS="junit-4"

inherit java-pkg-2 java-pkg-simple

DESCRIPTION="Table structures for SciJava."
HOMEPAGE="https://github.com/scijava/scijava-table"

if [[ ${PV} == 9999 ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/scijava/scijava-table.git"
S="${WORKDIR}/${P}"
MAVEN_ID="org.scijava:scijava-table:9999"
else
SRC_URI="
https://github.com/scijava/${PN}/archive/refs/tags/${P}.tar.gz -> ${P}-sources.tar.gz
"
S="${WORKDIR}/${PN}-${P}"
MAVEN_ID="org.scijava:scijava-table:1.0.3"
KEYWORDS="~amd64"
fi

LICENSE="BSD-2"
SLOT="0"

CDEPEND="
>=dev-java/scijava-common-2.89.0:0
>=dev-java/scijava-optional-1.0.1:0
"

BDEPEND="
>=virtual/jdk-1.8:*
${CDEPEND}
test? ( >=dev-java/junit-4.13.2:4 )
"

DEPEND="${CDEPEND}"

RDEPEND="
>=virtual/jre-1.8:*
${CDEPEND}
"

JAVA_GENTOO_CLASSPATH="scijava-common,scijava-optional"
JAVA_SRC_DIR="src/main/java"
JAVA_MAIN_CLASS=""

JAVA_TEST_GENTOO_CLASSPATH="junit-4"
JAVA_TEST_SRC_DIR="src/test/java"
54 changes: 54 additions & 0 deletions dev-java/scijava-table/scijava-table-9999.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,54 @@
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

JAVA_PKG_IUSE="doc source test"
JAVA_TESTING_FRAMEWORKS="junit-4"

inherit java-pkg-2 java-pkg-simple

DESCRIPTION="Table structures for SciJava."
HOMEPAGE="https://github.com/scijava/scijava-table"

if [[ ${PV} == 9999 ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/scijava/scijava-table.git"
S="${WORKDIR}/${P}"
MAVEN_ID="org.scijava:scijava-table:9999"
else
SRC_URI="
https://github.com/scijava/${PN}/archive/refs/tags/${P}.tar.gz -> ${P}-sources.tar.gz
"
S="${WORKDIR}/${PN}-${P}"
MAVEN_ID="org.scijava:scijava-table:1.0.3"
KEYWORDS="~amd64"
fi

LICENSE="BSD-2"
SLOT="0"

CDEPEND="
>=dev-java/scijava-common-2.89.0:0
>=dev-java/scijava-optional-1.0.1:0
"

BDEPEND="
>=virtual/jdk-1.8:*
${CDEPEND}
test? ( >=dev-java/junit-4.13.2:4 )
"

DEPEND="${CDEPEND}"

RDEPEND="
>=virtual/jre-1.8:*
${CDEPEND}
"

JAVA_GENTOO_CLASSPATH="scijava-common,scijava-optional"
JAVA_SRC_DIR="src/main/java"
JAVA_MAIN_CLASS=""

JAVA_TEST_GENTOO_CLASSPATH="junit-4"
JAVA_TEST_SRC_DIR="src/test/java"

0 comments on commit b3ed66a

Please sign in to comment.