Skip to content

Commit

Permalink
dev-java/parsington: new package, add 3.1.0, 9999
Browse files Browse the repository at this point in the history
Signed-off-by: IAHMCOL <[email protected]>
Closes: #1200
Signed-off-by: Andrew Ammerlaan <[email protected]>
  • Loading branch information
IAHM-COL authored and Nowa-Ammerlaan committed Aug 17, 2023
1 parent 941a028 commit cbd7dba
Show file tree
Hide file tree
Showing 4 changed files with 111 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-java/parsington/Manifest
Original file line number Diff line number Diff line change
@@ -0,0 +1 @@
DIST parsington-3.1.0-sources.tar.gz 45883 BLAKE2B 39d37c772ba12f845fc6a53762e474f534dbb4920bc7178e885d560550a60c4e3949406d94a604b2b8740b9d337a504783111ccf28d480da10454db55abe853c SHA512 d1596e67b691148838116a02a88b2c520f0887952d254939cec0c77f225601be5f7d19f44c6b310126c7d210c726ec3399d77f8d91d590c377a2cd22814a68a7
14 changes: 14 additions & 0 deletions dev-java/parsington/metadata.xml
Original file line number Diff line number Diff line change
@@ -0,0 +1,14 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<longdescription>
Parsington is an infix-to-postfix and infix-to-syntax-tree expression parser for mathematical expressions written in Java. It is simple yet fancy, handling (customizable) operators, functions, variables and constants in a similar way to what the Java language itself supports.
</longdescription>
<maintainer type="project">
<email>[email protected]</email>
<name>Gentoo Science Project</name>
</maintainer>
<upstream>
<remote-id type="github">scijava/parsington</remote-id>
</upstream>
</pkgmetadata>
48 changes: 48 additions & 0 deletions dev-java/parsington/parsington-3.1.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,48 @@
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

JAVA_PKG_IUSE="doc source test"
JAVA_TESTING_FRAMEWORKS="junit-jupiter"

inherit java-pkg-2 java-pkg-simple

DESCRIPTION="A mathematical expression parser for infix expression strings"
HOMEPAGE="https://github.com/scijava/parsington"

if [[ ${PV} == 9999 ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/scijava/parsington.git"
S="${WORKDIR}/${P}"
MAVEN_ID="org.scijava:parsington:9999"
else
SRC_URI="
https://github.com/scijava/${PN}/archive/refs/tags/${P}.tar.gz -> ${P}-sources.tar.gz
"
S="${WORKDIR}/${PN}-${P}"
MAVEN_ID="org.scijava:parsington:3.1.0"
KEYWORDS="~amd64"
fi

LICENSE="BSD-2"
SLOT="0"

CDEPEND=">=dev-java/junit-5.9.1:5"

BDEPEND="
>=virtual/jdk-1.8:*
test? (
"${CDEPEND}"
)
"

DEPEND="${CDEPEND}"

RDEPEND=">=virtual/jre-1.8:*"

JAVA_SRC_DIR="src/main/java"
JAVA_MAIN_CLASS="org.scijava.parsington.Main"

JAVA_TEST_GENTOO_CLASSPATH="junit-5"
JAVA_TEST_SRC_DIR="src/test/java"
48 changes: 48 additions & 0 deletions dev-java/parsington/parsington-9999.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,48 @@
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

JAVA_PKG_IUSE="doc source test"
JAVA_TESTING_FRAMEWORKS="junit-jupiter"

inherit java-pkg-2 java-pkg-simple

DESCRIPTION="A mathematical expression parser for infix expression strings"
HOMEPAGE="https://github.com/scijava/parsington"

if [[ ${PV} == 9999 ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/scijava/parsington.git"
S="${WORKDIR}/${P}"
MAVEN_ID="org.scijava:parsington:9999"
else
SRC_URI="
https://github.com/scijava/${PN}/archive/refs/tags/${P}.tar.gz -> ${P}-sources.tar.gz
"
S="${WORKDIR}/${PN}-${P}"
MAVEN_ID="org.scijava:parsington:3.1.0"
KEYWORDS="~amd64"
fi

LICENSE="BSD-2"
SLOT="0"

CDEPEND=">=dev-java/junit-5.9.1:5"

BDEPEND="
>=virtual/jdk-1.8:*
test? (
"${CDEPEND}"
)
"

DEPEND="${CDEPEND}"

RDEPEND=">=virtual/jre-1.8:*"

JAVA_SRC_DIR="src/main/java"
JAVA_MAIN_CLASS="org.scijava.parsington.Main"

JAVA_TEST_GENTOO_CLASSPATH="junit-5"
JAVA_TEST_SRC_DIR="src/test/java"

0 comments on commit cbd7dba

Please sign in to comment.