Skip to content

Commit

Permalink
Add Changelog, bump version to 0.3.0
Browse files Browse the repository at this point in the history
  • Loading branch information
gentoo90 committed Jul 11, 2015
1 parent 3187963 commit edab6e7
Show file tree
Hide file tree
Showing 3 changed files with 22 additions and 3 deletions.
2 changes: 1 addition & 1 deletion Cargo.toml
Original file line number Diff line number Diff line change
@@ -1,6 +1,6 @@
[package]
name = "winreg"
version = "0.2.6"
version = "0.3.0"
authors = ["Igor Shaula <[email protected]>"]
license = "MIT"
description = "Rust bindings to MS Windows Registry API"
Expand Down
15 changes: 14 additions & 1 deletion README.md
Original file line number Diff line number Diff line change
Expand Up @@ -23,6 +23,7 @@ Current features:
```rust
extern crate winreg;
use std::path::Path;
use std::io;
use winreg::RegKey;
use winreg::enums::*;

Expand Down Expand Up @@ -59,7 +60,12 @@ fn main() {
hkcu.delete_subkey_all(&path).unwrap();

println!("Trying to open nonexisting key...");
println!("{:?}", hkcu.open_subkey(&path).unwrap_err());
let key2 = hkcu.open_subkey(&path)
.unwrap_or_else(|e| match e.kind() {
io::ErrorKind::NotFound => panic!("Key doesn't exist"),
io::ErrorKind::PermissionDenied => panic!("Access denied"),
_ => panic!("{:?}", e)
});
}
```

Expand Down Expand Up @@ -191,3 +197,10 @@ fn main() {
println!("Equal to encoded: {:?}", v1 == v2);
}
```

## Changelog

### 0.3.0

* Add transactions support and make serialization transacted
* Breaking change: use `std::io::{Error,Result}` instead of own `RegError` and `RegResult`
8 changes: 7 additions & 1 deletion examples/basic_usage.rs
Original file line number Diff line number Diff line change
Expand Up @@ -5,6 +5,7 @@
// except according to those terms.
extern crate winreg;
use std::path::Path;
use std::io;
use winreg::RegKey;
use winreg::enums::*;

Expand Down Expand Up @@ -41,5 +42,10 @@ fn main() {
hkcu.delete_subkey_all(&path).unwrap();

println!("Trying to open nonexisting key...");
println!("{:?}", hkcu.open_subkey(&path).unwrap_err());
let key2 = hkcu.open_subkey(&path)
.unwrap_or_else(|e| match e.kind() {
io::ErrorKind::NotFound => panic!("Key doesn't exist"),
io::ErrorKind::PermissionDenied => panic!("Access denied"),
_ => panic!("{:?}", e)
});
}

0 comments on commit edab6e7

Please sign in to comment.