Skip to content

Commit

Permalink
Merge branch 'develop' for MeTA v2.0.1
Browse files Browse the repository at this point in the history
  • Loading branch information
skystrife committed Feb 5, 2016
2 parents 6c062bf + 8050007 commit 7d7540c
Show file tree
Hide file tree
Showing 15 changed files with 402 additions and 175 deletions.
19 changes: 17 additions & 2 deletions .travis.yml
Original file line number Diff line number Diff line change
Expand Up @@ -62,11 +62,26 @@ matrix:
- clang-3.6
- llvm-3.6-dev

# OSX/Clang (XCode)
# OS X 10.9 + Xcode 6.1
- os: osx
env: COMPILER=clang

# OSX/GCC 5
# OS X 10.10 + Xcode 6.4
- os: osx
osx_image: xcode6.4
env: COMPILER=clang

# OS X 10.10 + Xcode 7.1.1
- os: osx
osx_image: xcode7.1
env: COMPILER=clang

# OS X 10.11 + Xcode 7.2
- os: osx
osx_image: xcode7.2
env: COMPILER=clang

# OS X/GCC 5
- os: osx
env: COMPILER=gcc

Expand Down
21 changes: 20 additions & 1 deletion CHANGELOG.md
Original file line number Diff line number Diff line change
@@ -1,3 +1,21 @@
# [v2.0.1][2.0.1]
## Bug fixes
- Fix issue where `metadata_parser` would not consume spaces in string
metadata fields. Thanks to @hopsalot on the forum for the bug report!
- Fix build issue on OS X with Xcode 6.4 and `clang` related to their
shipped version of `string_view` lacking a const `to_string()` method

## Enhancements
- The `./profile` executable ensures that the file exists before operating on
it. Thanks to @domarps for the PR!
- Add a generic `util::multiway_merge` algorithm for performing the
merge-step of an external memory merge sort.
- Build with the following Xcode versions on Travis CI:
* Xcode 6.1 and OS X 10.9 (as before)
* Xcode 6.4 and OS X 10.10 (new)
* Xcode 7.1.1 and OS X 10.10 (new)
* Xcode 7.2 and OS X 10.11 (new)

# [v2.0.0][2.0.0]
## New features and major changes

Expand Down Expand Up @@ -286,7 +304,8 @@
# [v1.0][1.0]
- Initial release.

[unreleased]: https://github.com/meta-toolkit/meta/compare/v2.0.0...develop
[unreleased]: https://github.com/meta-toolkit/meta/compare/v2.0.1...develop
[2.0.1]: https://github.com/meta-toolkit/meta/compare/v2.0.0...v2.0.1
[2.0.0]: https://github.com/meta-toolkit/meta/compare/v1.3.8...v2.0.0
[1.3.8]: https://github.com/meta-toolkit/meta/compare/v1.3.7...v1.3.8
[1.3.7]: https://github.com/meta-toolkit/meta/compare/v1.3.6...v1.3.7
Expand Down
5 changes: 4 additions & 1 deletion CMakeLists.txt
Original file line number Diff line number Diff line change
Expand Up @@ -214,7 +214,10 @@ endif()
check_cxx_source_compiles("
#include <experimental/string_view>
int main() {
std::experimental::string_view sv = \"hello world\";
const std::experimental::string_view sv = \"hello world\";
// test that string_view has to_string() const method
// Xcode 6.4 appears to have shipped a string_view without it
auto str = sv.to_string();
return 0;
}" META_HAS_EXPERIMENTAL_STRING_VIEW)

Expand Down
2 changes: 1 addition & 1 deletion LICENSE.mit
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
Copyright (c) 2015 Sean Massung, Chase Geigle
Copyright (c) 2016 Sean Massung, Chase Geigle

Permission is hereby granted, free of charge, to any person obtaining a copy of
this software and associated documentation files (the "Software"), to deal in
Expand Down
4 changes: 2 additions & 2 deletions LICENSE.ncsa
Original file line number Diff line number Diff line change
@@ -1,9 +1,9 @@
Copyright (c) 2015 Sean Massung, Chase Geigle
Copyright (c) 2016 Sean Massung, Chase Geigle
All rights reserved.

Developed by: MeTA Team
University of Illinois at Urbana-Champaign
http://meta-toolkit.github.io/meta/
https://meta-toolkit.org

Permission is hereby granted, free of charge, to any person obtaining a copy of
this software and associated documentation files (the "Software"), to deal with
Expand Down
2 changes: 1 addition & 1 deletion README.md
Original file line number Diff line number Diff line change
Expand Up @@ -470,7 +470,7 @@ you should run the following commands to download dependencies and related
software needed for building:

```bash
pacman -Syu git mingw-w64-x86_64-{gcc,cmake,make,icu,jemalloc}
pacman -Syu git make mingw-w64-x86_64-{gcc,cmake,icu,jemalloc}
```

Then, exit the shell and launch the "MinGW-w64 Win64" shell. You can obtain
Expand Down
2 changes: 1 addition & 1 deletion cmake/FindOrBuildICU.cmake
Original file line number Diff line number Diff line change
Expand Up @@ -74,7 +74,7 @@ function(FindOrBuildICU)
PREFIX ${ICU_EP_PREFIX}
URL ${FindOrBuildICU_URL}
URL_HASH ${FindOrBuildICU_URL_HASH}
CONFIGURE_COMMAND ${ICU_EP_PREFIX}/src/ExternalICU/source/runConfigureICU ${ICU_PLATFORM}
CONFIGURE_COMMAND CC=${CMAKE_C_COMPILER} CXX=${CMAKE_CXX_COMPILER} ${ICU_EP_PREFIX}/src/ExternalICU/source/runConfigureICU ${ICU_PLATFORM}
--disable-shared --enable-static --disable-dyload --disable-extras
--disable-tests --disable-samples
--prefix=<INSTALL_DIR>
Expand Down
2 changes: 1 addition & 1 deletion deps/cpptoml
Loading

0 comments on commit 7d7540c

Please sign in to comment.