Skip to content

Commit

Permalink
Merge branch 'openwrt:main' into v16-luci-eht
Browse files Browse the repository at this point in the history
  • Loading branch information
nextgen-networks authored Oct 21, 2024
2 parents 88c0c35 + f9da81d commit b943ad5
Show file tree
Hide file tree
Showing 200 changed files with 28,005 additions and 967 deletions.
4 changes: 2 additions & 2 deletions include/kernel-6.6
Original file line number Diff line number Diff line change
@@ -1,2 +1,2 @@
LINUX_VERSION-6.6 = .56
LINUX_KERNEL_HASH-6.6.56 = f74812f78e88992c416434cb107639e13a551dbaff36bb90d6346ab16ab71a95
LINUX_VERSION-6.6 = .57
LINUX_KERNEL_HASH-6.6.57 = 66ce426ef96f99b8e1ef7ac72e780c730ef8b970f7aa5708501c4274d7abb7b3
3 changes: 2 additions & 1 deletion include/version.mk
Original file line number Diff line number Diff line change
Expand Up @@ -104,5 +104,6 @@ VERSION_SED_SCRIPT:=$(SED) 's,%U,$(call sed_escape,$(VERSION_REPO)),g' \
-e 's,%u,$(call sed_escape,$(VERSION_HOME_URL)),g' \
-e 's,%s,$(call sed_escape,$(VERSION_SUPPORT_URL)),g' \
-e 's,%P,$(call sed_escape,$(VERSION_PRODUCT)),g' \
-e 's,%h,$(call sed_escape,$(VERSION_HWREV)),g'
-e 's,%h,$(call sed_escape,$(VERSION_HWREV)),g' \
-e 's,%B,$(call sed_escape,$(SOURCE_DATE_EPOCH)),g'

2 changes: 1 addition & 1 deletion package/base-files/files/bin/config_generate
Original file line number Diff line number Diff line change
Expand Up @@ -314,7 +314,7 @@ generate_static_system() {
set system.@system[-1].hostname='OpenWrt'
set system.@system[-1].timezone='UTC'
set system.@system[-1].ttylogin='0'
set system.@system[-1].log_size='64'
set system.@system[-1].log_size='128'
set system.@system[-1].urandom_seed='0'
delete system.ntp
Expand Down
5 changes: 5 additions & 0 deletions package/base-files/files/lib/functions/uci-defaults.sh
Original file line number Diff line number Diff line change
Expand Up @@ -122,6 +122,11 @@ ucidef_set_network_device_path() {
_ucidef_set_network_device_common $1 path $2
}

ucidef_set_network_device_path_port() {
_ucidef_set_network_device_common $1 path $2
_ucidef_set_network_device_common $1 port $3
}

ucidef_set_network_device_gro() {
_ucidef_set_network_device_common $1 gro $2
}
Expand Down
20 changes: 18 additions & 2 deletions package/base-files/files/lib/preinit/10_indicate_preinit
Original file line number Diff line number Diff line change
Expand Up @@ -65,12 +65,27 @@ preinit_config_switch() {

preinit_config_port() {
local original
local dev_port

local netdev="$1"
local path="$2"
local port="$3"

[ -d "/sys/devices/$path/net" ] || return
original="$(ls "/sys/devices/$path/net" | head -1)"

if [ -z "$port" ]; then
original="$(ls "/sys/devices/$path/net" | head -1)"
else
for device in /sys/devices/$path/net/*; do
dev_port="$(cat "$device/dev_port")"
if [ "$dev_port" = "$port" ]; then
original="${device##*/}"
break
fi
done

[ -z "$original" ] && return
fi

[ "$netdev" = "$original" ] && return

Expand Down Expand Up @@ -109,7 +124,8 @@ preinit_config_board() {
json_select "network_device"
json_select "$netdev"
json_get_vars path path
[ -n "$path" ] && preinit_config_port "$netdev" "$path"
json_get_vars port port
[ -n "$path" ] && preinit_config_port "$netdev" "$path" "$port"
json_select ..
json_select ..
done
Expand Down
1 change: 1 addition & 0 deletions package/base-files/files/usr/lib/os-release
Original file line number Diff line number Diff line change
Expand Up @@ -16,3 +16,4 @@ OPENWRT_DEVICE_MANUFACTURER_URL="%m"
OPENWRT_DEVICE_PRODUCT="%P"
OPENWRT_DEVICE_REVISION="%h"
OPENWRT_RELEASE="%D %V %C"
OPENWRT_BUILD_DATE="%B"
9 changes: 8 additions & 1 deletion package/boot/uboot-ath79/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -25,7 +25,14 @@ define U-Boot/ar9344_nec_aterm
UBOOT_CONFIG:=nec_ar9344_aterm
endef

UBOOT_TARGETS := ar9344_nec_aterm
define U-Boot/qca9558_nec_aterm
NAME:=NEC Aterm series (QCA9558)
BUILD_SUBTARGET:= generic
BUILD_DEVICES:=nec_wg1400hp nec_wg1800hp nec_wg1800hp2
UBOOT_CONFIG:=nec_qca9558_aterm
endef

UBOOT_TARGETS := ar9344_nec_aterm qca9558_nec_aterm

# don't stage files to bindir, let target/linux/ath79/image/*.mk do that
define Package/u-boot/install
Expand Down
Loading

0 comments on commit b943ad5

Please sign in to comment.