forked from openwrt/openwrt
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Merge branch 'openwrt:main' into v14_luci-be-eht-danpawlik-rmadrad
- Loading branch information
Showing
76 changed files
with
2,423 additions
and
409 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,2 +1,2 @@ | ||
LINUX_VERSION-6.6 = .53 | ||
LINUX_KERNEL_HASH-6.6.53 = 285d181d1b252b0bf905f040d094215cf183ac98c31a17f9cce9f3537ef4d779 | ||
LINUX_VERSION-6.6 = .54 | ||
LINUX_KERNEL_HASH-6.6.54 = 5fae869d6a24055c16ffc2d92669e3fb2b258e34d36c850bb8cf9def417ecfa0 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
|
@@ -9,12 +9,12 @@ include $(TOPDIR)/rules.mk | |
include $(INCLUDE_DIR)/kernel.mk | ||
|
||
PKG_NAME:=strace | ||
PKG_VERSION:=6.7 | ||
PKG_VERSION:=6.11 | ||
PKG_RELEASE:=1 | ||
|
||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz | ||
PKG_SOURCE_URL:=https://strace.io/files/$(PKG_VERSION) | ||
PKG_HASH:=2090201e1a3ff32846f4fe421c1163b15f440bb38e31355d09f82d3949922af7 | ||
PKG_HASH:=83262583a3529f02c3501aa8b8ac772b4cbc03dc934e98bab6e4883626e283a5 | ||
|
||
PKG_MAINTAINER:=Felix Fietkau <[email protected]> | ||
PKG_LICENSE:=LGPL-2.1-or-later | ||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
|
@@ -8,12 +8,12 @@ | |
include $(TOPDIR)/rules.mk | ||
|
||
PKG_NAME:=valgrind | ||
PKG_VERSION:=3.22.0 | ||
PKG_VERSION:=3.23.0 | ||
PKG_RELEASE:=1 | ||
|
||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2 | ||
PKG_SOURCE_URL:=https://sourceware.org/pub/valgrind/ | ||
PKG_HASH:=c811db5add2c5f729944caf47c4e7a65dcaabb9461e472b578765dd7bf6d2d4c | ||
PKG_HASH:=c5c34a3380457b9b75606df890102e7df2c702b9420c2ebef9540f8b5d56264d | ||
|
||
PKG_MAINTAINER:=Felix Fietkau <[email protected]> | ||
PKG_LICENSE:=GPL-2.0+ | ||
|
61 changes: 61 additions & 0 deletions
61
...age/devel/valgrind/patches/010-486180-Valgrind-MIPS-VexGuestArchState-has-no-member.patch
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,61 @@ | ||
From 7214886886bce9029f325214156c02dcfff760d5 Mon Sep 17 00:00:00 2001 | ||
From: Paul Floyd <[email protected]> | ||
Date: Sat, 27 Apr 2024 13:07:07 +0200 | ||
Subject: 486180 - [Valgrind][MIPS] 'VexGuestArchState' has no member named | ||
'guest_IP_AT_SYSCALL' | ||
|
||
--- | ||
NEWS | 34 ++++++++++++++++++++++++++++++++++ | ||
VEX/priv/guest_mips_helpers.c | 4 ++++ | ||
VEX/pub/libvex_guest_mips32.h | 6 +++--- | ||
VEX/pub/libvex_guest_mips64.h | 2 ++ | ||
configure.ac | 6 +++--- | ||
5 files changed, 46 insertions(+), 6 deletions(-) | ||
|
||
--- a/VEX/priv/guest_mips_helpers.c | ||
+++ b/VEX/priv/guest_mips_helpers.c | ||
@@ -187,6 +187,8 @@ void LibVEX_GuestMIPS32_initialise( /*OU | ||
vex_state->guest_w1.w64[1] = 0; | ||
vex_state->guest_w2.w64[0] = 0; | ||
vex_state->guest_w2.w64[1] = 0; | ||
+ | ||
+ vex_state->guest_IP_AT_SYSCALL = 0; | ||
} | ||
|
||
void LibVEX_GuestMIPS64_initialise ( /*OUT*/ VexGuestMIPS64State * vex_state ) | ||
@@ -294,6 +296,8 @@ void LibVEX_GuestMIPS64_initialise ( /*O | ||
vex_state->guest_LLaddr = 0xFFFFFFFFFFFFFFFFULL; | ||
vex_state->guest_LLdata = 0; | ||
|
||
+ vex_state->guest_IP_AT_SYSCALL = 0; | ||
+ | ||
vex_state->guest_MSACSR = 0; | ||
} | ||
|
||
--- a/VEX/pub/libvex_guest_mips32.h | ||
+++ b/VEX/pub/libvex_guest_mips32.h | ||
@@ -188,10 +188,10 @@ typedef | ||
|
||
/* 1016 */ UInt guest_MSACSR; | ||
|
||
- /* 1020 */ UInt _padding3; | ||
+ /* 1020 */ UInt guest_IP_AT_SYSCALL; | ||
|
||
- /* 1020 */ ULong guest_LLdata64; | ||
- /* 1028 */ ULong _padding4; | ||
+ /* 1024 */ ULong guest_LLdata64; | ||
+ /* 1032 */ ULong _padding3; | ||
} VexGuestMIPS32State; | ||
/*---------------------------------------------------------------*/ | ||
/*--- Utility functions for MIPS32 guest stuff. ---*/ | ||
--- a/VEX/pub/libvex_guest_mips64.h | ||
+++ b/VEX/pub/libvex_guest_mips64.h | ||
@@ -184,6 +184,8 @@ typedef | ||
/* 1144 */ UInt guest_MSACSR; | ||
|
||
/* 1148 */ UInt _padding2; | ||
+ /* 1152 */ ULong guest_IP_AT_SYSCALL; | ||
+ /* 1160 */ ULong _padding3; | ||
|
||
} VexGuestMIPS64State; | ||
|
143 changes: 0 additions & 143 deletions
143
package/devel/valgrind/patches/010-mips-Fix-new-syscall-numbers.patch
This file was deleted.
Oops, something went wrong.
Oops, something went wrong.