Skip to content

Commit

Permalink
package/asterisk: update patches to be applied with fuzz 0
Browse files Browse the repository at this point in the history
Commit 8f88a64 "support/scripts/apply-patches.sh: set the maximum
fuzz factor to 0" reduced the fuzz factor.

Due to this change, asterisk fails to build with output:

    Applying 0004-install-samples-need-the-data-files.patch using patch:
    patching file Makefile
    Hunk #1 FAILED at 779.
    1 out of 1 hunk FAILED -- saving rejects to file Makefile.rej

This commit rebase the package patches on the current package version.
Note: the patch 0005 is unchanged, as it is correct in its current
state.

Fixes:
- http://autobuild.buildroot.org/results/92d/92d58ecb67f11a6eb74695bc1efcc672f69a57a9

Signed-off-by: Julien Olivain <[email protected]>
Signed-off-by: Yann E. MORIN <[email protected]>
  • Loading branch information
jolivain authored and yann-morin-1998 committed Jun 27, 2024
1 parent de278d6 commit a6fabd9
Show file tree
Hide file tree
Showing 4 changed files with 26 additions and 19 deletions.
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
From 3e8a9e9a1c7eae515eb628778c3c8a04338b3bb3 Mon Sep 17 00:00:00 2001
From 63f685e468bef94d8938b7a9c1a18c6c00840219 Mon Sep 17 00:00:00 2001
From: "Yann E. MORIN" <[email protected]>
Date: Tue, 27 Dec 2016 11:21:09 +0100
Subject: [PATCH] sounds: do not download and check sha1s
Expand All @@ -20,16 +20,18 @@ However, that poses at least two problems:

So we just do without the sha1 download and checks.

Signed-off-by: Julien Olivain <[email protected]>
[Julien: rebase patch on tag 20.7.0]
Signed-off-by: "Yann E. MORIN" <[email protected]>
---
sounds/Makefile | 10 ----------
1 file changed, 10 deletions(-)

diff --git a/sounds/Makefile b/sounds/Makefile
index 84d0f45..7a80d56 100644
index 288b8139a9..260434e504 100644
--- a/sounds/Makefile
+++ b/sounds/Makefile
@@ -100,17 +100,7 @@ ifneq ($(SOUNDS_CACHE_DIR),)
@@ -101,17 +101,7 @@ ifneq ($(SOUNDS_CACHE_DIR),)
if test ! -f "$$(SOUNDS_CACHE_DIR)/$$@"; then \
(cd "$$(SOUNDS_CACHE_DIR)"; $$(DOWNLOAD) $$(SOUNDS_URL)/$$@); \
fi; \
Expand All @@ -48,5 +50,5 @@ index 84d0f45..7a80d56 100644
else
$(CMD_PREFIX) \
--
2.7.4
2.45.2

13 changes: 7 additions & 6 deletions package/asterisk/0002-configure-fix-detection-of-libcrypt.patch
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
From 8996503f6c55e55f326ab11c18278954ad7abaf3 Mon Sep 17 00:00:00 2001
From e959097b00357a2fd5f140daf3114c2245cd6b95 Mon Sep 17 00:00:00 2001
From: "Yann E. MORIN" <[email protected]>
Date: Tue, 27 Dec 2016 11:21:57 +0100
Subject: [PATCH] configure: fix detection of libcrypt
Expand All @@ -15,17 +15,18 @@ and thus concludes that crypt is missing when it was successfully found.
Fix that by also storing the result of either check in the 'CRYPT'
scheme.

Signed-off-by: Julien Olivain <[email protected]>
[Julien: rebase patch on tag 20.7.0]
Signed-off-by: "Yann E. MORIN" <[email protected]>
---
configure | 2 ++
configure.ac | 2 ++
2 files changed, 4 insertions(+)
1 file changed, 2 insertions(+)

diff --git a/configure.ac b/configure.ac
index 121dd93..d459ff5 100644
index 639bcd9df3..16f4297634 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2406,10 +2406,12 @@ AC_CHECK_FUNC([crypt], [SYSCRYPT=true], [SYSCRYPT=""])
@@ -2694,10 +2694,12 @@ AC_CHECK_FUNC([crypt], [SYSCRYPT=true], [SYSCRYPT=""])
if test "x$LIBCRYPT_LIB" != "x" ; then
CRYPT_LIB="$LIBCRYPT_LIB"
CRYPT_INCLUDE="$LIBCRYPT_INCLUDE"
Expand All @@ -39,5 +40,5 @@ index 121dd93..d459ff5 100644
fi

--
2.7.4
2.45.2

Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
From 933b2554a40f932571bdbdbb5217cda3e35fd61f Mon Sep 17 00:00:00 2001
From 93edc41d3ae60e6ee9b9bbb7cdcc592133521fa3 Mon Sep 17 00:00:00 2001
From: "Yann E. MORIN" <[email protected]>
Date: Mon, 27 Nov 2017 12:52:52 +0100
Subject: [PATCH] build: ensure target directory for modules exists
Expand All @@ -9,16 +9,18 @@ modules fails because the target directory does not exist yet.
We fix that by instructing $(INSTALL) to create the destination directory
first.

Signed-off-by: Julien Olivain <[email protected]>
[Julien: rebase patch on tag 20.7.0]
Signed-off-by: "Yann E. MORIN" <[email protected]>
---
Makefile.moddir_rules | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/Makefile.moddir_rules b/Makefile.moddir_rules
index 59190bece9..b73153a9a5 100644
index 795b32c716..7d5e5d241a 100644
--- a/Makefile.moddir_rules
+++ b/Makefile.moddir_rules
@@ -110,7 +110,7 @@ clean::
@@ -106,7 +106,7 @@ clean::

install:: all
@echo "Installing modules from `basename $(CURDIR)`..."
Expand All @@ -28,5 +30,5 @@ index 59190bece9..b73153a9a5 100644
@if [ -f .moduleinfo ] ; then \
declare -A DISABLED_MODS ;\
--
2.11.0
2.45.2

12 changes: 7 additions & 5 deletions package/asterisk/0004-install-samples-need-the-data-files.patch
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
From 05680ea9899c2246c23d11860c2c8e10aa8f80c7 Mon Sep 17 00:00:00 2001
From d347deb0376a3254d7cd8bbfe46dd645d1bf1061 Mon Sep 17 00:00:00 2001
From: "Yann E. MORIN" <[email protected]>
Date: Fri, 1 Dec 2017 11:08:16 +0100
Subject: [PATCH] install: samples need the data files
Expand All @@ -12,24 +12,26 @@ installed at the time we try to generate the voicemail data.

Ensure the needed dependency.

Signed-off-by: Julien Olivain <[email protected]>
[Julien: rebase patch on tag 20.7.0]
Signed-off-by: "Yann E. MORIN" <[email protected]>
---
Makefile | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/Makefile b/Makefile
index f29c07f680..b58f707b61 100644
index 7ef73342cc..bb60f5e380 100644
--- a/Makefile
+++ b/Makefile
@@ -779,7 +779,7 @@ adsi:
@@ -819,7 +819,7 @@ adsi:
$(INSTALL) -m 644 "$$x" "$(DESTDIR)$(ASTETCDIR)/`$(BASENAME) $$x`" ; \
done

-samples: adsi
+samples: adsi datafiles
@echo Installing other config files...
$(call INSTALL_CONFIGS,samples,.sample)
$(call INSTALL_CONFIGS,configs/samples,.sample)
$(INSTALL) -d "$(DESTDIR)$(ASTSPOOLDIR)/voicemail/default/1234/INBOX"
--
2.11.0
2.45.2

0 comments on commit a6fabd9

Please sign in to comment.