forked from buildroot/buildroot
-
Notifications
You must be signed in to change notification settings - Fork 1
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Commit 8f88a64 "support/scripts/apply-patches.sh: set the maximum fuzz factor to 0" reduced the fuzz factor. Due to this change, eigen fails to build with output: Applying 0001-Adds-new-CMake-Options-for-controlling-build-components.patch using patch: patching file CMakeLists.txt Hunk #1 succeeded at 495 (offset 18 lines). Hunk #2 succeeded at 615 (offset 1 line). Hunk buildroot#3 succeeded at 652 (offset -8 lines). patching file blas/CMakeLists.txt patching file lapack/CMakeLists.txt Hunk #1 FAILED at 1. Hunk #2 succeeded at 450 (offset -7 lines). 1 out of 2 hunks FAILED -- saving rejects to file lapack/CMakeLists.txt.rej This commit refreshes the package patch on the current package version. Since the patch file name changed in the regeneration, the ".checkpackageignore" entry is updated accordingly. Fixes: http://autobuild.buildroot.org/results/6fd059b4e7f83a38683341ea1ea02e13d1a92449 Signed-off-by: Julien Olivain <[email protected]> Signed-off-by: Yann E. MORIN <[email protected]>
- Loading branch information
1 parent
e1c86e1
commit ddd7910
Showing
2 changed files
with
15 additions
and
12 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,22 +1,24 @@ | ||
From cf82186416d04ea5df2a397d8fe09dc78d40ca65 Mon Sep 17 00:00:00 2001 | ||
From f49d5c1a6b7c22be359189cd0b1e2e766bd05365 Mon Sep 17 00:00:00 2001 | ||
From: =?UTF-8?q?Antonio=20S=C3=A1nchez?= <[email protected]> | ||
Date: Sat, 5 Mar 2022 05:49:45 +0000 | ||
Subject: [PATCH] Adds new CMake Options for controlling build components. | ||
|
||
[Retrieved from: | ||
https://gitlab.com/libeigen/eigen/-/commit/cf82186416d04ea5df2a397d8fe09dc78d40ca65] | ||
Signed-off-by: Fabrice Fontaine <[email protected]> | ||
[Julien: rebased patch on 3.4.0] | ||
Signed-off-by: Julien Olivain <[email protected]> | ||
--- | ||
CMakeLists.txt | 6 ++++++ | ||
blas/CMakeLists.txt | 3 ++- | ||
lapack/CMakeLists.txt | 5 +++++ | ||
3 files changed, 13 insertions(+), 1 deletion(-) | ||
|
||
diff --git a/CMakeLists.txt b/CMakeLists.txt | ||
index de1c23e91..0af36a53a 100644 | ||
index f3e69b845..74ff755f5 100644 | ||
--- a/CMakeLists.txt | ||
+++ b/CMakeLists.txt | ||
@@ -477,6 +477,9 @@ if(EIGEN_BUILD_TESTING) | ||
@@ -495,6 +495,9 @@ if(BUILD_TESTING) | ||
add_subdirectory(failtest) | ||
endif() | ||
|
||
|
@@ -26,7 +28,7 @@ index de1c23e91..0af36a53a 100644 | |
if(EIGEN_LEAVE_TEST_IN_ALL_TARGET) | ||
add_subdirectory(blas) | ||
add_subdirectory(lapack) | ||
@@ -611,6 +614,8 @@ set_target_properties (eigen PROPERTIES EXPORT_NAME Eigen) | ||
@@ -612,6 +615,8 @@ set_target_properties (eigen PROPERTIES EXPORT_NAME Eigen) | ||
|
||
install (TARGETS eigen EXPORT Eigen3Targets) | ||
|
||
|
@@ -35,7 +37,7 @@ index de1c23e91..0af36a53a 100644 | |
configure_package_config_file ( | ||
${CMAKE_CURRENT_SOURCE_DIR}/cmake/Eigen3Config.cmake.in | ||
${CMAKE_CURRENT_BINARY_DIR}/Eigen3Config.cmake | ||
@@ -655,6 +660,7 @@ install (FILES ${CMAKE_CURRENT_BINARY_DIR}/Eigen3Config.cmake | ||
@@ -647,6 +652,7 @@ install ( FILES ${CMAKE_CURRENT_SOURCE_DIR}/cmake/UseEigen3.cmake | ||
# Add uninstall target | ||
add_custom_target ( uninstall | ||
COMMAND ${CMAKE_COMMAND} -P ${CMAKE_CURRENT_SOURCE_DIR}/cmake/EigenUninstall.cmake) | ||
|
@@ -44,7 +46,7 @@ index de1c23e91..0af36a53a 100644 | |
if (EIGEN_SPLIT_TESTSUITE) | ||
ei_split_testsuite("${EIGEN_SPLIT_TESTSUITE}") | ||
diff --git a/blas/CMakeLists.txt b/blas/CMakeLists.txt | ||
index 8d3cb86dc..c530957fb 100644 | ||
index f3a94ec4a..d07090f69 100644 | ||
--- a/blas/CMakeLists.txt | ||
+++ b/blas/CMakeLists.txt | ||
@@ -1,6 +1,7 @@ | ||
|
@@ -55,31 +57,32 @@ index 8d3cb86dc..c530957fb 100644 | |
include(CheckLanguage) | ||
check_language(Fortran) | ||
if(CMAKE_Fortran_COMPILER) | ||
@@ -59,4 +60,4 @@ if(EIGEN_BUILD_TESTING) | ||
@@ -59,4 +60,4 @@ if(BUILD_TESTING) | ||
endif() | ||
|
||
endif() | ||
- | ||
+endif() | ||
diff --git a/lapack/CMakeLists.txt b/lapack/CMakeLists.txt | ||
index c8ca64001..8d6d75401 100644 | ||
index e48497fda..71255d96d 100644 | ||
--- a/lapack/CMakeLists.txt | ||
+++ b/lapack/CMakeLists.txt | ||
@@ -1,5 +1,7 @@ | ||
@@ -1,6 +1,8 @@ | ||
|
||
project(EigenLapack CXX) | ||
|
||
+if(EIGEN_BUILD_LAPACK AND EIGEN_BUILD_BLAS) | ||
+ | ||
include(CheckLanguage) | ||
check_language(Fortran) | ||
if(CMAKE_Fortran_COMPILER) | ||
@@ -457,3 +459,6 @@ if(EXISTS ${eigen_full_path_to_testing_lapack}) | ||
@@ -450,3 +452,6 @@ if(EXISTS ${eigen_full_path_to_testing_lapack}) | ||
|
||
endif() | ||
|
||
+elseif(EIGEN_BUILD_LAPACK AND NOT EIGEN_BUILD_BLAS) | ||
+ message(FATAL_ERROR "EIGEN_BUILD_LAPACK requires EIGEN_BUILD_BLAS") | ||
+endif() #EIGEN_BUILD_LAPACK | ||
-- | ||
GitLab | ||
2.45.2 | ||
|