forked from buildroot/buildroot
-
Notifications
You must be signed in to change notification settings - Fork 1
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
package/mongrel2: update the patches to be applied with fuzz 0
Commit 8f88a64 ("support/scripts/apply-patches.sh: set the maximum fuzz factor to 0") reduced the fuzz factor. Due to this change, mongrel2 fails to build with output: Applying 0001-Do-not-run-tests.patch using patch: patching file Makefile Hunk #1 FAILED at 16. 1 out of 1 hunk FAILED -- saving rejects to file Makefile.rej patching file tools/m2sh/Makefile Hunk #1 FAILED at 9. 1 out of 1 hunk FAILED -- saving rejects to file tools/m2sh/Makefile.rej Applying 0003-fix-build-with-gcc-4.8.patch using patch: patching file Makefile patching file tools/m2sh/Makefile Hunk #1 FAILED at 10. 1 out of 2 hunks FAILED -- saving rejects to file tools/m2sh/Makefile.rej This commit refreshes the package patches on the current package version. Signed-off-by: Dario Binacchi <[email protected]> Signed-off-by: Thomas Petazzoni <[email protected]>
- Loading branch information
1 parent
2be1f20
commit f7ea606
Showing
3 changed files
with
15 additions
and
12 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
|
@@ -7,6 +7,8 @@ This patch is specific to cross-compiled environments and avoids running | |
the tests on the host. It is not meant to be applied upstream. | ||
|
||
Signed-off-by: Lionel Orry <[email protected]> | ||
[Dario: make the patch to be applied with fuzz factor 0] | ||
Signed-off-by: Dario Binacchi <[email protected]> | ||
--- | ||
Makefile | 2 +- | ||
tools/m2sh/Makefile | 2 +- | ||
|
@@ -16,22 +18,22 @@ diff --git a/Makefile b/Makefile | |
index 7dc4089..ca72630 100644 | ||
--- a/Makefile | ||
+++ b/Makefile | ||
@@ -16,7 +16,7 @@ TEST_SRC=$(wildcard tests/*_tests.c) | ||
@@ -18,7 +18,7 @@ | ||
TESTS=$(patsubst %.c,%,${TEST_SRC}) | ||
MAKEOPTS=OPTFLAGS="${NOEXTCFLAGS} ${OPTFLAGS}" OPTLIBS="${OPTLIBS}" LIBS="${LIBS}" DESTDIR="${DESTDIR}" PREFIX="${PREFIX}" | ||
MAKEOPTS=OPTFLAGS="${CFLAGS} ${NOEXTCFLAGS} ${OPTFLAGS}" LDFLAGS="${LDFLAGS}" LIBS="${LIBS}" DESTDIR="${DESTDIR}" PREFIX="${PREFIX}" | ||
|
||
-all: bin/mongrel2 tests m2sh procer | ||
+all: bin/mongrel2 m2sh procer filters config_modules | ||
|
||
dev: CFLAGS=-g -Wall -Isrc -Wall -Wextra $(OPTFLAGS) -D_FILE_OFFSET_BITS=64 | ||
dev: all | ||
${OBJECTS_NOEXT}: CFLAGS += ${NOEXTCFLAGS} | ||
${OBJECTS}: | builddirs | ||
diff --git a/tools/m2sh/Makefile b/tools/m2sh/Makefile | ||
index b50d8a0..334e4da 100644 | ||
--- a/tools/m2sh/Makefile | ||
+++ b/tools/m2sh/Makefile | ||
@@ -9,7 +9,7 @@ TESTS=$(patsubst %.c,%,${TEST_SRC}) | ||
LIB_SRC=$(filter-out src/m2sh.c,${SOURCES}) | ||
LIB_OBJ=$(filter-out src/m2sh.o,${OBJECTS}) | ||
@@ -12,7 +12,7 @@ | ||
|
||
$(RAGEL_OBJECTS): CFLAGS += -Wno-unused-const-variable -Wimplicit-fallthrough=0 -Wno-unused-parameter | ||
|
||
-all: ../lemon/lemon tests build/m2sh | ||
+all: ../lemon/lemon build/m2sh | ||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
|
@@ -15,7 +15,9 @@ Fixes: | |
- http://autobuild.buildroot.org/results/de324b733e09057c87352220069fe65f6e535eb8 | ||
|
||
Signed-off-by: Fabrice Fontaine <[email protected]> | ||
[Upstream status: https://github.com/mongrel2/mongrel2/pull/354] | ||
Upstream: https://github.com/mongrel2/mongrel2/pull/354 | ||
[Dario: make the patch to be applied with fuzz factor 0] | ||
Signed-off-by: Dario Binacchi <[email protected]> | ||
--- | ||
Makefile | 1 - | ||
tools/m2sh/Makefile | 4 ++-- | ||
|
@@ -37,16 +39,16 @@ diff --git a/tools/m2sh/Makefile b/tools/m2sh/Makefile | |
index 83e7ae4..86364af 100644 | ||
--- a/tools/m2sh/Makefile | ||
+++ b/tools/m2sh/Makefile | ||
@@ -10,7 +10,7 @@ LIB_SRC=$(filter-out src/m2sh.c,${SOURCES}) | ||
@@ -10,7 +10,7 @@ | ||
LIB_OBJ=$(filter-out src/m2sh.o,${OBJECTS}) | ||
RAGEL_OBJECTS=src/lexer.o src/cli.o | ||
|
||
-$(RAGEL_OBJECTS): CFLAGS += -Wno-unused-const-variable -Wimplicit-fallthrough=0 -Wno-unused-parameter | ||
+$(RAGEL_OBJECTS): CFLAGS += -Wno-unused-parameter | ||
|
||
all: ../lemon/lemon tests build/m2sh | ||
all: ../lemon/lemon build/m2sh | ||
|
||
@@ -20,7 +20,7 @@ dev: all | ||
@@ -20,7 +20,7 @@ | ||
install: build/m2sh | ||
install build/m2sh ${DESTDIR}${PREFIX}/bin | ||
|
||
|