Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Feat(eos_designs): Add support to use router general for router id #4687

Merged
Show file tree
Hide file tree
Changes from 5 commits
Commits
File filter

Filter by extension

Filter by extension

Conversations
Failed to load comments.
Loading
Jump to
Jump to file
Failed to load files.
Loading
Diff view
Diff view
Original file line number Diff line number Diff line change
Expand Up @@ -67,9 +67,9 @@ mpls:
ip: true
ldp:
interface_disabled_default: true
router_id: 10.255.0.1
shutdown: false
transport_address_interface: Loopback0
router_id: 10.255.0.1
ethernet_interfaces:
- name: Ethernet1
peer: pe1
Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -67,9 +67,9 @@ mpls:
ip: true
ldp:
interface_disabled_default: true
router_id: 10.255.0.2
shutdown: false
transport_address_interface: Loopback0
router_id: 10.255.0.2
ethernet_interfaces:
- name: Ethernet2
peer: pe1
Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -67,9 +67,9 @@ mpls:
ip: true
ldp:
interface_disabled_default: true
router_id: 10.255.0.3
shutdown: false
transport_address_interface: Loopback0
router_id: 10.255.0.3
ethernet_interfaces:
- name: Ethernet2
peer: rr1
Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -67,9 +67,9 @@ mpls:
ip: true
ldp:
interface_disabled_default: true
router_id: 10.255.0.4
shutdown: false
transport_address_interface: Loopback0
router_id: 10.255.0.4
ethernet_interfaces:
- name: Ethernet2
peer: rr2
Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -157,9 +157,9 @@ mpls:
ip: true
ldp:
interface_disabled_default: true
router_id: 10.255.1.1
shutdown: false
transport_address_interface: Loopback0
router_id: 10.255.1.1
router_bfd:
multihop:
interval: 300
Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -157,9 +157,9 @@ mpls:
ip: true
ldp:
interface_disabled_default: true
router_id: 10.255.1.2
shutdown: false
transport_address_interface: Loopback0
router_id: 10.255.1.2
router_bfd:
multihop:
interval: 300
Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -157,9 +157,9 @@ mpls:
ip: true
ldp:
interface_disabled_default: true
router_id: 10.255.1.3
shutdown: false
transport_address_interface: Loopback0
router_id: 10.255.1.3
router_bfd:
multihop:
interval: 300
Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -128,9 +128,9 @@ mpls:
ip: true
ldp:
interface_disabled_default: true
router_id: 10.255.2.1
shutdown: false
transport_address_interface: Loopback0
router_id: 10.255.2.1
router_bfd:
multihop:
interval: 300
Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -128,9 +128,9 @@ mpls:
ip: true
ldp:
interface_disabled_default: true
router_id: 10.255.2.2
shutdown: false
transport_address_interface: Loopback0
router_id: 10.255.2.2
router_bfd:
multihop:
interval: 300
Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -200,9 +200,9 @@ mpls:
ip: true
ldp:
interface_disabled_default: true
router_id: 100.70.0.5
shutdown: false
transport_address_interface: Loopback0
router_id: 100.70.0.5
router_bfd:
multihop:
interval: 300
Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -245,9 +245,9 @@ mpls:
ip: true
ldp:
interface_disabled_default: true
router_id: 100.70.0.6
shutdown: false
transport_address_interface: Loopback0
router_id: 100.70.0.6
router_bfd:
multihop:
interval: 300
Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -80,9 +80,9 @@ mpls:
ip: true
ldp:
interface_disabled_default: true
router_id: 100.70.0.1
shutdown: false
transport_address_interface: Loopback0
router_id: 100.70.0.1
ethernet_interfaces:
- name: Ethernet1
peer: SITE1-LER1
Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -80,9 +80,9 @@ mpls:
ip: true
ldp:
interface_disabled_default: true
router_id: 100.70.0.2
shutdown: false
transport_address_interface: Loopback0
router_id: 100.70.0.2
ethernet_interfaces:
- name: Ethernet1
peer: SITE1-LER2
Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -156,9 +156,9 @@ mpls:
ip: true
ldp:
interface_disabled_default: true
router_id: 100.70.0.8
shutdown: false
transport_address_interface: Loopback0
router_id: 100.70.0.8
router_bfd:
multihop:
interval: 300
Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -254,9 +254,9 @@ mpls:
ip: true
ldp:
interface_disabled_default: true
router_id: 100.70.0.7
shutdown: false
transport_address_interface: Loopback0
router_id: 100.70.0.7
router_bfd:
multihop:
interval: 300
Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -80,9 +80,9 @@ mpls:
ip: true
ldp:
interface_disabled_default: true
router_id: 100.70.0.3
shutdown: false
transport_address_interface: Loopback0
router_id: 100.70.0.3
ethernet_interfaces:
- name: Ethernet3
peer: SITE1-LSR1
Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -80,9 +80,9 @@ mpls:
ip: true
ldp:
interface_disabled_default: true
router_id: 100.70.0.4
shutdown: false
transport_address_interface: Loopback0
router_id: 100.70.0.4
ethernet_interfaces:
- name: Ethernet3
peer: SITE1-LSR2
Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -156,9 +156,9 @@ mpls:
ip: true
ldp:
interface_disabled_default: true
router_id: 100.70.0.9
shutdown: false
transport_address_interface: Loopback0
router_id: 100.70.0.9
router_bfd:
multihop:
interval: 300
Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -83,9 +83,9 @@ mpls:
ip: true
ldp:
interface_disabled_default: true
router_id: 100.70.0.10
shutdown: false
transport_address_interface: Loopback0
router_id: 100.70.0.10
ip_igmp_snooping:
globally_enabled: true
ip_virtual_router_mac_address: 00:1c:73:00:dc:00
Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -190,7 +190,6 @@ router bfd
multihop interval 1200 min-rx 1200 multiplier 3
!
router bgp 65001
router-id 192.168.255.4
update wait-install
no bgp default ipv4-unicast
maximum-paths 4 ecmp 4
Expand Down Expand Up @@ -300,4 +299,8 @@ router bgp 65001
no neighbor EVPN-OVERLAY-PEERS activate
neighbor UNDERLAY-PEERS activate
!
router general
router-id ipv4 192.168.255.4
exit
!
end
Original file line number Diff line number Diff line change
Expand Up @@ -299,14 +299,17 @@ ip route vrf MGMT 0.0.0.0/0 192.168.0.1
mpls ip
!
mpls ldp
router-id 10.0.0.1
transport-address interface Loopback0
interface disabled default
no shutdown
!
router general
router-id ipv4 10.0.0.1
router-id ipv6 2000:1234:ffff:ffff::1
exit
!
router isis CORE
net 49.0001.0100.0000.0001.00
router-id ipv4 10.0.0.1
is-type level-2
log-adjacency-changes
mpls ldp sync default
Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -207,13 +207,16 @@ ip route vrf MGMT 0.0.0.0/0 192.168.0.1
mpls ip
!
mpls ldp
ClausHolbechArista marked this conversation as resolved.
Show resolved Hide resolved
router-id 10.0.0.2
transport-address interface Loopback0
interface disabled default
no shutdown
!
router general
router-id ipv4 10.0.0.2
router-id ipv6 2000:1234:ffff:ffff::2
exit
!
router ospf 101
router-id 10.0.0.2
bfd default
passive-interface default
no passive-interface Ethernet1
Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -2,7 +2,6 @@ hostname: DC1-SPINE4
is_deployed: true
router_bgp:
as: '65001'
router_id: 192.168.255.4
bgp_defaults:
- distance bgp 20 200 200
bgp:
Expand Down Expand Up @@ -264,6 +263,10 @@ ntp:
snmp_server:
contact: [email protected]
location: EOS_DESIGNS_UNIT_TESTS DC1-SPINE4
router_general:
router_id:
ipv4: 192.168.255.4
ipv6: null
ClausHolbechArista marked this conversation as resolved.
Show resolved Hide resolved
ethernet_interfaces:
- name: Ethernet1/1
peer: DC1-LEAF1A
Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -27,6 +27,10 @@ management_api_http:
enable_vrfs:
- name: MGMT
enable_https: true
router_general:
router_id:
ipv4: 10.0.0.1
ipv6: 2000:1234:ffff:ffff::1
loopback_interfaces:
- name: Loopback0
description: ROUTER_ID
Expand All @@ -45,7 +49,6 @@ router_isis:
instance: CORE
log_adjacency_changes: true
net: 49.0001.0100.0000.0001.00
router_id: 10.0.0.1
is_type: level-2
address_family_ipv4:
enabled: true
Expand All @@ -71,7 +74,6 @@ mpls:
ip: true
ldp:
interface_disabled_default: true
router_id: 10.0.0.1
shutdown: false
transport_address_interface: Loopback0
ethernet_interfaces:
Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -27,6 +27,10 @@ management_api_http:
enable_vrfs:
- name: MGMT
enable_https: true
router_general:
router_id:
ipv4: 10.0.0.2
ipv6: 2000:1234:ffff:ffff::2
loopback_interfaces:
- name: Loopback0
description: ROUTER_ID
Expand All @@ -41,7 +45,6 @@ router_ospf:
process_ids:
- id: 101
passive_interface_default: true
router_id: 10.0.0.2
max_lsa: 12000
no_passive_interfaces:
- Ethernet1
Expand All @@ -59,7 +62,6 @@ mpls:
ip: true
ldp:
interface_disabled_default: true
router_id: 10.0.0.2
shutdown: false
transport_address_interface: Loopback0
ethernet_interfaces:
Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -71,6 +71,6 @@ mpls:
ip: true
ldp:
interface_disabled_default: true
router_id: 10.0.0.3
shutdown: false
transport_address_interface: Loopback0
router_id: 10.0.0.3
Original file line number Diff line number Diff line change
Expand Up @@ -2,6 +2,8 @@
# If the device is set to "is_deployed: false" at the host_vars level, then do not shutdown interfaces towards undeployed peers.
shutdown_interfaces_towards_undeployed_peers: false

use_router_general_for_router_id: true

# If the device is set to "is_deployed: false" at the host_vars level, then do not shutdown bgp towards undeployed peers.
shutdown_bgp_towards_undeployed_peers: false

Expand Down
Original file line number Diff line number Diff line change
@@ -1,2 +1,4 @@
---
underlay_routing_protocol: isis-sr-ldp
# Use router id from router general configuration
use_router_general_for_router_id: true
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
---
underlay_routing_protocol: ospf-ldp
use_router_general_for_router_id: true

Some generated files are not rendered by default. Learn more about how customized files appear on GitHub.

5 changes: 5 additions & 0 deletions python-avd/pyavd/_eos_designs/schema/eos_designs.schema.yml

Some generated files are not rendered by default. Learn more about how customized files appear on GitHub.

Loading
Loading