Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Feat(eos_designs): Add support to use router general for router id #4687

Merged
Show file tree
Hide file tree
Changes from all commits
Commits
File filter

Filter by extension

Filter by extension

Conversations
Failed to load comments.
Loading
Jump to
Jump to file
Failed to load files.
Loading
Diff view
Diff view
Original file line number Diff line number Diff line change
Expand Up @@ -241,9 +241,9 @@ router_ospf:
- id: 10
vrf: C1_VRF1
passive_interface_default: true
router_id: 10.255.1.1
no_passive_interfaces:
- Ethernet3.10
router_id: 10.255.1.1
redistribute:
bgp:
enabled: true
Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -241,9 +241,9 @@ router_ospf:
- id: 10
vrf: C1_VRF1
passive_interface_default: true
router_id: 10.255.1.2
no_passive_interfaces:
- Ethernet4.10
router_id: 10.255.1.2
redistribute:
bgp:
enabled: true
Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -236,9 +236,9 @@ router_ospf:
- id: 10
vrf: C1_VRF1
passive_interface_default: true
router_id: 10.255.1.3
no_passive_interfaces:
- Ethernet2
router_id: 10.255.1.3
redistribute:
bgp:
enabled: true
Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -470,10 +470,10 @@ router_ospf:
- id: 19
vrf: TENANT_B_INTRA
passive_interface_default: true
router_id: 10.123.1.0
no_passive_interfaces:
- Ethernet6.10
max_lsa: 10000
router_id: 10.123.1.0
redistribute:
bgp:
enabled: true
Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -583,10 +583,10 @@ router_ospf:
- id: 99
vrf: TENANT_B_WAN
passive_interface_default: true
router_id: 192.168.48.4
no_passive_interfaces:
- Ethernet6.100
max_lsa: 10000
router_id: 192.168.48.4
redistribute:
bgp:
enabled: true
Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -312,7 +312,6 @@ router bfd
multihop interval 1200 min-rx 1200 multiplier 3
!
router bgp 65104
router-id 192.168.255.14
update wait-install
no bgp default ipv4-unicast
maximum-paths 4 ecmp 4
Expand Down Expand Up @@ -414,7 +413,6 @@ router bgp 65104
rd 192.168.254.14:15
route-target import evpn 65104:15
route-target export evpn 65104:15
router-id 192.168.255.14
redistribute connected
!
vrf Tenant_A_WAN_Zone
Expand All @@ -425,7 +423,6 @@ router bgp 65104
route-target export evpn 65104:14
route-target export evpn 65000:789
route-target export vpn-ipv4 65000:123
router-id 192.168.255.14
update wait-install
neighbor 123.1.1.10 remote-as 1234
neighbor 123.1.1.10 shutdown
Expand Down Expand Up @@ -475,31 +472,30 @@ router bgp 65104
rd 192.168.254.14:20
route-target import evpn 65104:20
route-target export evpn 65104:20
router-id 192.168.255.14
redistribute connected
!
vrf Tenant_B_WAN_Zone
rd 192.168.254.14:21
route-target import evpn 65104:21
route-target export evpn 65104:21
router-id 192.168.255.14
redistribute connected
!
vrf Tenant_C_WAN_Zone
rd 192.168.254.14:31
route-target import evpn 65104:31
route-target export evpn 65104:31
router-id 192.168.255.14
redistribute connected
!
vrf TENANT_D_WAN_ZONE
rd 192.168.254.14:42
route-target import evpn 65104:42
route-target export evpn 65104:42
router-id 192.168.255.14
!
router general
router-id ipv4 192.168.255.14
exit
!
router ospf 14 vrf Tenant_A_WAN_Zone
router-id 192.168.255.14
passive-interface default
no passive-interface Ethernet7
no passive-interface Vlan150
Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -190,7 +190,6 @@ router bfd
multihop interval 1200 min-rx 1200 multiplier 3
!
router bgp 65001
router-id 192.168.255.4
update wait-install
no bgp default ipv4-unicast
maximum-paths 4 ecmp 4
Expand Down Expand Up @@ -300,4 +299,8 @@ router bgp 65001
no neighbor EVPN-OVERLAY-PEERS activate
neighbor UNDERLAY-PEERS activate
!
router general
router-id ipv4 192.168.255.4
exit
!
end
Original file line number Diff line number Diff line change
Expand Up @@ -299,14 +299,17 @@ ip route vrf MGMT 0.0.0.0/0 192.168.0.1
mpls ip
!
mpls ldp
router-id 10.0.0.1
transport-address interface Loopback0
interface disabled default
no shutdown
!
router general
router-id ipv4 10.0.0.1
router-id ipv6 2000:1234:ffff:ffff::1
exit
!
router isis CORE
net 49.0001.0100.0000.0001.00
router-id ipv4 10.0.0.1
is-type level-2
log-adjacency-changes
mpls ldp sync default
Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -207,13 +207,16 @@ ip route vrf MGMT 0.0.0.0/0 192.168.0.1
mpls ip
!
mpls ldp
ClausHolbechArista marked this conversation as resolved.
Show resolved Hide resolved
router-id 10.0.0.2
transport-address interface Loopback0
interface disabled default
no shutdown
!
router general
router-id ipv4 10.0.0.2
router-id ipv6 2000:1234:ffff:ffff::2
exit
!
router ospf 101
router-id 10.0.0.2
bfd default
passive-interface default
no passive-interface Ethernet1
Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -2,7 +2,6 @@ hostname: DC1-BL1A
is_deployed: true
router_bgp:
as: '65104'
router_id: 192.168.255.14
bgp_defaults:
- distance bgp 20 200 200
bgp:
Expand Down Expand Up @@ -131,7 +130,6 @@ router_bgp:
- address_family: evpn
route_targets:
- '65104:15'
router_id: 192.168.255.14
redistribute:
connected:
enabled: true
Expand All @@ -154,7 +152,6 @@ router_bgp:
- address_family: vpn-ipv4
route_targets:
- 65000:123
router_id: 192.168.255.14
redistribute:
connected:
enabled: true
Expand Down Expand Up @@ -228,7 +225,6 @@ router_bgp:
- address_family: evpn
route_targets:
- '65104:20'
router_id: 192.168.255.14
redistribute:
connected:
enabled: true
Expand All @@ -243,7 +239,6 @@ router_bgp:
- address_family: evpn
route_targets:
- '65104:21'
router_id: 192.168.255.14
redistribute:
connected:
enabled: true
Expand All @@ -258,7 +253,6 @@ router_bgp:
- address_family: evpn
route_targets:
- '65104:31'
router_id: 192.168.255.14
redistribute:
connected:
enabled: true
Expand All @@ -273,7 +267,6 @@ router_bgp:
- address_family: evpn
route_targets:
- '65104:42'
router_id: 192.168.255.14
vlan_aware_bundles:
- name: Tenant_A_WAN_Zone
rd: 192.168.254.14:14
Expand Down Expand Up @@ -452,6 +445,9 @@ ntp: null
snmp_server:
contact: [email protected]
location: EOS_DESIGNS_UNIT_TESTS DC1-BL1A
router_general:
router_id:
ipv4: 192.168.255.14
ethernet_interfaces:
- name: Ethernet1
peer: DC1-SPINE1
Expand Down Expand Up @@ -724,7 +720,6 @@ router_ospf:
- id: 14
vrf: Tenant_A_WAN_Zone
passive_interface_default: true
router_id: 192.168.255.14
no_passive_interfaces:
- Ethernet7
- Vlan150
Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -692,10 +692,10 @@ router_ospf:
- id: 14
vrf: Tenant_A_WAN_Zone
passive_interface_default: true
router_id: 192.168.255.15
no_passive_interfaces:
- Vlan150
max_lsa: 15000
router_id: 192.168.255.15
redistribute:
bgp:
enabled: true
Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -569,9 +569,9 @@ router_ospf:
- id: 9
vrf: Tenant_A_OP_Zone
passive_interface_default: true
router_id: 192.168.42.42
no_passive_interfaces:
- Vlan113
router_id: 192.168.42.42
redistribute:
bgp:
enabled: true
Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -1226,10 +1226,10 @@ router_ospf:
- id: 16
vrf: Tenant_A_OSPF
passive_interface_default: true
router_id: 192.168.255.10
no_passive_interfaces:
- Ethernet22
- Ethernet23
router_id: 192.168.255.10
redistribute:
bgp:
enabled: true
Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -1166,9 +1166,9 @@ router_ospf:
- id: 16
vrf: Tenant_A_OSPF
passive_interface_default: true
router_id: 192.168.255.11
no_passive_interfaces:
- Ethernet24
router_id: 192.168.255.11
redistribute:
bgp:
enabled: true
Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -2,7 +2,6 @@ hostname: DC1-SPINE4
is_deployed: true
router_bgp:
as: '65001'
router_id: 192.168.255.4
bgp_defaults:
- distance bgp 20 200 200
bgp:
Expand Down Expand Up @@ -264,6 +263,9 @@ ntp:
snmp_server:
contact: [email protected]
location: EOS_DESIGNS_UNIT_TESTS DC1-SPINE4
router_general:
router_id:
ipv4: 192.168.255.4
ethernet_interfaces:
- name: Ethernet1/1
peer: DC1-LEAF1A
Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -472,12 +472,12 @@ router_ospf:
- id: 1
vrf: svi_profile_tests_vrf
passive_interface_default: true
router_id: 192.168.255.1
no_passive_interfaces:
- Vlan510
- Vlan511
- Vlan512
max_lsa: 15000
router_id: 192.168.255.1
redistribute:
bgp:
enabled: true
Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -344,12 +344,12 @@ router_ospf:
- id: 1
vrf: svi_profile_tests_vrf
passive_interface_default: true
router_id: 192.168.255.1
no_passive_interfaces:
- Vlan510
- Vlan511
- Vlan512
max_lsa: 15000
router_id: 192.168.255.1
redistribute:
bgp:
enabled: true
Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -27,6 +27,10 @@ management_api_http:
enable_vrfs:
- name: MGMT
enable_https: true
router_general:
router_id:
ipv4: 10.0.0.1
ipv6: 2000:1234:ffff:ffff::1
loopback_interfaces:
- name: Loopback0
description: ROUTER_ID
Expand All @@ -45,7 +49,6 @@ router_isis:
instance: CORE
log_adjacency_changes: true
net: 49.0001.0100.0000.0001.00
router_id: 10.0.0.1
is_type: level-2
address_family_ipv4:
enabled: true
Expand All @@ -71,7 +74,6 @@ mpls:
ip: true
ldp:
interface_disabled_default: true
router_id: 10.0.0.1
shutdown: false
transport_address_interface: Loopback0
ethernet_interfaces:
Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -27,6 +27,10 @@ management_api_http:
enable_vrfs:
- name: MGMT
enable_https: true
router_general:
router_id:
ipv4: 10.0.0.2
ipv6: 2000:1234:ffff:ffff::2
loopback_interfaces:
- name: Loopback0
description: ROUTER_ID
Expand All @@ -41,7 +45,6 @@ router_ospf:
process_ids:
- id: 101
passive_interface_default: true
router_id: 10.0.0.2
max_lsa: 12000
no_passive_interfaces:
- Ethernet1
Expand All @@ -59,7 +62,6 @@ mpls:
ip: true
ldp:
interface_disabled_default: true
router_id: 10.0.0.2
shutdown: false
transport_address_interface: Loopback0
ethernet_interfaces:
Expand Down
Loading
Loading