forked from openwrt/openwrt
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Merge branch 'openwrt:main' into v14_luci-be-eht-danpawlik-rmadrad
- Loading branch information
Showing
21 changed files
with
197 additions
and
130 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,7 +1,7 @@ | ||
include $(TOPDIR)/rules.mk | ||
|
||
PKG_NAME:=ath10k-ct | ||
PKG_RELEASE:=1 | ||
PKG_RELEASE:=2 | ||
|
||
PKG_LICENSE:=GPLv2 | ||
PKG_LICENSE_FILES:= | ||
|
@@ -12,10 +12,10 @@ PKG_SOURCE_DATE:=2024-07-30 | |
PKG_SOURCE_VERSION:=ac71b14dc93aef0af6f0f24808b0afb673eaa5f5 | ||
PKG_MIRROR_HASH:=f7774fc7002bbea450f543927acd528fb1bb6742f0e9ef28a402df3796893d93 | ||
|
||
# Build the 6.9 ath10k-ct driver version. | ||
# Build the 6.10 ath10k-ct driver version. | ||
# Probably this should match as closely as | ||
# possible to whatever mac80211 backports version is being used. | ||
CT_KVER="-6.9" | ||
CT_KVER="-6.10" | ||
|
||
PKG_MAINTAINER:=Ben Greear <[email protected]> | ||
PKG_BUILD_PARALLEL:=1 | ||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,11 +1,11 @@ | ||
--- a/ath10k-6.9/pci.c | ||
+++ b/ath10k-6.9/pci.c | ||
--- a/ath10k-6.10/pci.c | ||
+++ b/ath10k-6.10/pci.c | ||
@@ -3871,7 +3871,7 @@ static int __ath10k_pci_probe(struct pci | ||
int (*pci_hard_reset)(struct ath10k *ar); | ||
u32 (*targ_cpu_to_ce_addr)(struct ath10k *ar, u32 addr); | ||
|
||
- printk(KERN_INFO "ath10k 6.7 driver, optimized for CT firmware, probing pci device: 0x%x.\n", | ||
+ printk(KERN_INFO "ath10k 6.9 driver, optimized for CT firmware, probing pci device: 0x%x.\n", | ||
+ printk(KERN_INFO "ath10k 6.10 driver, optimized for CT firmware, probing pci device: 0x%x.\n", | ||
pci_dev->device); | ||
|
||
switch (pci_dev->device) { |
10 changes: 10 additions & 0 deletions
10
package/kernel/ath10k-ct/patches/002-ath10k-6.10-remove-unsupported-feature.patch
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,10 @@ | ||
--- a/ath10k-6.10/mac.c | ||
+++ b/ath10k-6.10/mac.c | ||
@@ -11626,7 +11626,6 @@ int ath10k_mac_register(struct ath10k *a | ||
ar->hw->wiphy->n_cipher_suites = ar->hw_params.n_cipher_suites; | ||
|
||
wiphy_ext_feature_set(ar->hw->wiphy, NL80211_EXT_FEATURE_CQM_RSSI_LIST); | ||
- wiphy_ext_feature_set(ar->hw->wiphy, NL80211_EXT_FEATURE_ETHTOOL_VDEV_STATS); | ||
|
||
ar->hw->weight_multiplier = ATH10K_AIRTIME_WEIGHT_MULTIPLIER; | ||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
|
@@ -39,9 +39,9 @@ that the feature is properly initialized: | |
|
||
Signed-off-by: Vincent Tremblay <[email protected]> | ||
|
||
--- a/ath10k-6.9/core.c | ||
+++ b/ath10k-6.9/core.c | ||
@@ -2889,14 +2889,14 @@ done: | ||
--- a/ath10k-6.10/core.c | ||
+++ b/ath10k-6.10/core.c | ||
@@ -2871,14 +2871,14 @@ done: | ||
static void ath10k_core_fetch_btcoex_dt(struct ath10k *ar) | ||
{ | ||
struct device_node *node; | ||
|
Oops, something went wrong.